Forums » Plugin: ActivityPub » No posts are available

  • Resolved andrewescott

    (@andrewescott)


    I am running the ActivityPub plugin version 1.0.10 on self-hosted WordPress 6.3.2 (https://aes.id.au), with the plugin configured with “enable authors” disabled and “enable blog” enabled, and blog profile ID is “andrew@aes.id.au”. I am experiencing the following issue:

    • Mastodon instance (@andrew@aus.social) is able to follow my blog (@andrew@aes.id.au), and this is reflected in the Followers panel of the plugin settings.
    • However, when I make a new post (I made one a couple of hours ago, for example), this is not sent out to the follower.

    Previously I had an issue with Webfinger not working, so the blog couldn’t even be followed. However, this was fixed by changing the permalinks to something other than plain permalinks.

    Can someone please suggest what should be done to get the ActivityPub plugin working for me?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter andrewescott

    (@andrewescott)

    It’s now solved. I had enabled DISABLE_WP_CRON previously to help with efficiency, and set up a daily cron job to run /wp-cron.php

    Since my post was less than 24 hrs previous, and the ActivityPub plugin is hooked into WP Cron events, the post hadn’t been sent out. I spotted this after installing the WP Crontrol plugin and looking at the waiting WP Cron events. I’ve since updated my cron job to run /wp-cron.php every 15 minutes.

    Plugin Author Matthias Pfefferle

    (@pfefferle)

    Oh, nice that you found the issue yourself! Let us know if we can help with something else or if you have some feedback 🙂

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.