Support » Theme: P2 » No Posting Options on P2 Page

  • A newbie to WordPress and looking for some advice on why this is not working.

    Trying to setup an internal communications system using P2, I have installed the Multiple Themes plugin so that I can have the P2 theme on a seperate page this all seems to work fine apart from the P2 doesn’t give me the options to post.

    Have I missed something else or do I need to change something else to enable this ?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The posting option of P2 appears on the main posts page – which will be either the front of your site, or on the page you’ve selected under Settings > Reading.

    If you make sure you have P2 on that page, and not another page that doesn’t list posts, and you should be good to go (it’s working well on a test site for me, assuming we’re running the same plugin.

    Thanks for the response Chad – I’ve changed the post page to a static page which is the one which has the P2 theme, it now displays the posts on there but doesn’t give any options to post etc.

    Are you viewing the pages when logged in as an admin?

    It’s working smoothly when I test it with the same settings you’ve described, so being logged out is the first thing that comes to mind as a problem.

    Yes that was the problem Chad I wasn’t logged in – Now when I try to post a message I get a Whoops P2 cannot connect to the server floating error.

    Hm. That hadn’t popped up for me when testing before, but I’m seeing it now as well. It looks something in the way this plugin pulls in secondary themes triggers a connection error in P2.

    After a quick look at the code that triggers the error, I’m not sure these two are going to be compatible.

    Possible workaround – install a separate WordPress site on a subdomain (updates.yourdomain.com or something like that) and run P2 on that install?

    That way P2 is the primary theme, so you shouldn’t run into trouble. You could also set up the menus on both sites match, so they experience was as seamless as possible.

    I’m presuming that you have setup the same way as me with just the P2 page as a seperate rule in the Multiple Theses plugin and not as the main WordPress theme.

    I’m wondering if I flip that around so P2 is the main theme & all the other pages us the Nimbus theme.

    Any thoughts on if that would work ?

    I had the same thought actually, but I ran into the error again when I tried it.

    I activated P2 as the main theme, then set a rule to use another theme on any url: example.com/*

    and I left the rule in place for the blog page.

    Sadly, same error – so it looks like something in the way the plugin displays the themes that you have rules for that’s getting in the way

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No Posting Options on P2 Page’ is closed to new replies.