Support » Plugin: Easy FancyBox » No popups since 1.7

  • Resolved newslicer

    (@newslicer)


    Hello Support,

    from 1.7 on the framed popup within images is broken for all my images in my posts.

    It only works correct with the featured image.

    All other images in my posts are shown without a popup based on the real URL.

    Is this a bug or something i have to configure?

    Please checke the following example page: https://www.videospielgeschichten.de/frueher-war-alles-besser/

    Any help would be great!

    Thanks in advance. Andre.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Hello Support,

    With great satisfication I worked all the time with Easy Fancy Box. Works great!
    Received today the message to update to version 1.7. So, I did. But ….
    I have the same problem. Update to Version 1.7 and it seems Easy Fancy Box is not working at all, specially for my PDF’s.
    Wordpress version 4.7.10
    Theme: WOffice
    PHP version 5.5

    This must be a bug. Please help us.
    Thanks in advance,
    Jos

    Plugin Author RavanH

    (@ravanh)

    Hi, thanks for reporting. I’m still trying to discover what is causing your issue. @andre do you know if you have PHP 5.5 on your hosting platform too?

    Plugin Author RavanH

    (@ravanh)

    OK, looking at your site page source I notice your theme is adding it’s own jquery library in the footer instead of using the one that comes with WordPress:

    
    <script type='text/javascript' src='https://www.videospielgeschichten.de/wp-content/themes/beeanca/assets/js/jquery.min.js?ver=4.9.5'></script>
    

    The problem is that this overwrites the first instance of jQuery in which FancyBox was added.

    Is there an option in your theme to NOT add the jQuery library?

    Note that the featured image is handled by the theme’s own light box https://www.videospielgeschichten.de/wp-content/themes/beeanca/assets/plugins/image-lightbox/main.js?ver=4.9.5

    • This reply was modified 1 year, 7 months ago by RavanH.

    Hello @ravanh,

    thank you very much for your replys.

    First: my website is using PHP 7.0

    Second: Easy FancyBox was working great until 7.0 with my theme. I am technical not aware on how to “NOT add the jQuery library” and would not want to change my theme basically here.

    Please help!

    Plugin Author RavanH

    (@ravanh)

    Is there no such option in the theme settings?

    Unfortunately not.

    There must be a way. It worked fine before with your amazing plugin.

    I’m sure it must be a bug. I did a rollback on my site for Easy Fancy Box and it is working like I expected. My PDF’s are shown in a pop-up window.
    Kind regard,
    Jos

    Plugin Author RavanH

    (@ravanh)

    @josbeerens your issue might be the same or it might be different, I have no idea. Can you create a new thread and share your site link there? I’ll have a look and tell you what is going wrong 🙂

    @newslicer the old version inserted the script files later than it does now. That caused the theme jQuery to not interfere with FancyBox operation but in the new version, the script files are loaded just a little bit earlier and now, the theme jQuery does cause trouble. Is there a way for you to contact the theme developers so they can fix the theme so it does not include a custom jQuery but instead use the one included with WordPress? As it is implemented now, I’d be surprised if this did not cause incompatibility with other plugins that use jQuery too…

    The quickest fix for you at this point (before it’s fixed in the theme) seems to be to revert Easy FancyBox to version 1.6.2 https://downloads.wordpress.org/plugin/easy-fancybox.1.6.2.zip

    @ravanh: ok, I just made a downgrade to 1.6.2 and now the plugin works again. Thanks for this solution and your quick replies! Great support.

    Unfortunately I can’s contact my themes dev because there out of business. The fact that I cannot upgrade the plugin from now on makes me sad. If there is any way I could fix the themes problem myself might be a way. I just don’t know what to do technically 🙁

    Plugin Author RavanH

    (@ravanh)

    With a little help, it might be easier than you think. Try this:

    1. Make sure you have a full copy of all your theme files in /wp-content/themes/beeanca/ locally, and that you can upload files via FTP if you need to restore.
    2. Now go in your WordPress admin to Appearance > Editor and click “I understand” in the notice.
    3. In the theme files list on the right, select Theme Functions (functions.php)
    4. Click the file content area (in the center of the screen) to put your cursor anywhere (does not matter where)
    5. Press the Ctrl+F keys on your keyboard to open a search field at the top of the content area
    6. Now enter jquery.min there and hit Enter to search for that string
    7. Now copy the lines that contain this string (and maybe the ones before and after) and post them here on this forum.

    I’ll take a look and advise on how to modify 🙂

    Thanks for your reply @ravanh.

    In the meantime I decided to switch my WordPress theme anyway because of GDPR/EU-DSGVO comparability. After that I assume your plugin will work out great.

    Kind regards for your support!

    Plugin Author RavanH

    (@ravanh)

    There is a new section in the latest version with theme compatibility options where you can change the position of the inserted script, represented by a number. The default position is 10 but if you make that number higher (like it was with Easy FancyBox 1.6 and older) it might solve the issue right away.

    If not, jest let me know 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘No popups since 1.7’ is closed to new replies.