Support » Plugin: Surbma | Age Verification Yes/No Popup » No popup for woocommerce single product page

  • Resolved baltas

    (@baltas)


    Hi, having trouble setting the popup for all the product pages.
    Supposedly this a post type page, so switching all posts button does not work, putting the custom post slug name on the “CPT single pages” field doesn’t do nothing also, but if on the post ID field I put a product ID it works, but this will not be an option since I can’t put all product ID there as they are too many so too much work.

    Do you have any idea to solve this?
    Meanwhile going to take a look on all your plugin code to see if I can came out with something.

Viewing 3 replies - 1 through 3 (of 3 total)
  • baltas

    (@baltas)

    Solve it.
    The problem was the apostrophes since you say on the CPT field:
    “CPT slugs in apostrophes, comma separated”

    but using this after saving the system escapes them with \ and doesn’t work.
    As soon I entered the post type names without the apostrophes all started working!

    Plugin Author Surbma

    (@surbma)

    Hi @baltas,

    thank you for sharing your experience with me! I will take a look and test it. When I have a fix, I will let you know.

    Plugin Author Surbma

    (@surbma)

    Hi @baltas,

    the plugin is updated, new version is out. I have made a big change, by dynamically show all available post types. Now you only have to choose, on which post type do you want to show the popup.

    IMPORTANT! You have to set the options again, because this version is not backward compatible! After update go to settings and set these options again!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘No popup for woocommerce single product page’ is closed to new replies.