Support » Plugin: Mailchimp for WooCommerce » No pop up for connecting to mailchimp account

  • peeter1682

    (@peeter1682)


    WP version: 5.8.1
    WooCommerce version: 5.7.1
    Mailchimp for WooComm.. version: 2.5.3
    PHP version: 7.4

    Hello,

    I am not able to connect Mailchimp account through the Mailchimp fro WooCommerce plugin. I can click “Connect Account” btn, but no pop up with login is showing.

    I checked javascript console and see these errors (removed domain name):

    Uncaught TypeError: i is null
        278 https://sub.mydomain.com/wp-content/plugins/woocommerce/packages/woocommerce-admin/dist/app/index.js?ver=2.6.5:2
        278 https://sub.mydomain.com/wp-content/plugins/woocommerce/packages/woocommerce-admin/dist/app/index.js?ver=2.6.5:2
        a https://sub.mydomain.com/wp-content/plugins/woocommerce/packages/woocommerce-admin/dist/app/index.js?ver=2.6.5:2
        app https://sub.mydomain.com/wp-content/plugins/woocommerce/packages/woocommerce-admin/dist/app/index.js?ver=2.6.5:2
        <anonymous> https://sub.mydomain.com/wp-content/plugins/woocommerce/packages/woocommerce-admin/dist/app/index.js?ver=2.6.5:2
    index.js:2:118656

    After re-clicking “Connect Account” btn this error shows:
    XHRPOSThttps://sub.mydomain.com/wp-admin/admin-ajax.php?_fs_blog_admin=true -- Bad Request

    after reading through error message it says:

    strict-origin-when-cross-origin

    I am working on Linux Firefox, though I tried using Chrome and even trying to connect through Windows (Chrome), without any result.

    Is there any solution for this?

Viewing 12 replies - 1 through 12 (of 12 total)
  • same here..

    Same issue. Have you found any solution?

    Plugin Support Jordan

    (@builtbyjordan)

    Hello all.

    This sort of behavior usually occurs if the “Block pop-up windows” is enabled in a browser such as in Firefox. However, there should still be a modal that displays alerting that Pop-ups are blocked and will need to be unblocked in order to connect Mailchimp. If the additional modal is not showing up, is it possible there are any other security or privacy extensions at play here?

    Have you tried navigating to this site with a browser with 0 extensions and still encounter the same behaviour?

    Hi Jordan, it’s not a browser problem.. on the activation screen of the plugin there are two choices: login or register.. if i click on “register” it correctly opens a modal window with form, if i click on “login” nothing happens..
    (tried with safari, chrome and firefox)

    wordpress and plugins are updated to latest versions

    Plugin Support Jordan

    (@builtbyjordan)

    @marcods thanks for the extra details. We’re getting other reports of this happening as well and our developers are looking into it.

    We’ll chime back in once we know what a solution will be. Although I can’t give a specific time frame as to when it can be worked out. I can assure you we’re working on it now. If it turns out we need to do a patch.

    Here is another thread you can follow as well. We’re combining them:
    https://github.com/mailchimp/mc-woocommerce/issues/804

    Plugin Author ryanhungate

    (@ryanhungate)

    @peeter1682 @alex_marin_29 @marcods this has us scratching our heads… how could the ajaxurl not be the same domain as in context at that time while viewing the plugin page?

    Are you using anything special here? Is it a multisite? Subdomain vs. Subfolder setup?

    Can you please show us any important information related to your setup so we can try to troubleshoot?

    Plugin Author ryanhungate

    (@ryanhungate)

    @peeter1682 @alex_marin_29 @marcods

    We did want to point out that this plugin makes use of the admin-ajax file for the oauth process, and it seems as if you’re getting stuck right at step 1 which is being done on your server side.

    The first “start request” when you click the authenticate button has to first call your server… which then calls our authentication server ( server to server ) to start this auth process securely.

    We would need you to check with your host to make sure this admin-ajax call is not being blocked for whatever reason… because the referrer on our test store is also the same strict-origin-when-cross-origin and it’s working just fine for us.

    Thread Starter peeter1682

    (@peeter1682)

    @ryanhungate Hello!

    few things changed… we moved installation of the WordPress & WooCommerce from subdomain to the main domain. Page is NOT multi-site. Just regular single WP installation running WordPress with DIVI theme.

    Server hosting is FastPanel interface running Nginx & Apache2.

    I tried reinstalling the plugin and going through activation again and…

    Firefox, nor Chrome browser, no longer logs any cross-origin error when hitting the CONNECT ACCOUNT button. I can see it sending POST request to url:

    /wp-admin/admin-ajax.php?_fs_blog_admin=true

    with content:

    action=mailchimp_woocommerce_oauth_start

    Unfortunattely response is 400 Bad request.

    —————————

    I tried doing fresh install of WP & DIVI & WooCommerce & Mailchimp for WooCommerce on the same hosting (no other plugins etc. installed) and authentication popup window for Mailchimp will show.

    I also noticed (in this fresh setup) that during the load of the page with configuration of the plugin.

    /wp-admin/admin.php?page=mailchimp-woocommerce

    I see AJAX loader animation at the bottom of the page content and I cannot see that on the main domain of my client’s page.

    Not sure if all of this will help you any…

    Plugin Author ryanhungate

    (@ryanhungate)

    @peeter1682 thanks for the feedback here. Can you please tell us whether or not you’re getting an auth window for Mailchimp, or is it blocking the auth window from even popping up?

    The only thing we’re curious about is this _fs_blog_admin=true because that’s a new one. We’re not sure what this is, or if it’s doing anything at all in the back end which might be causing trouble. The fact it’s got a query referencing the admin really makes us curious.

    Have you tried disabling this plugin that might be adding this?

    @ryanhungate thanks for your answer.
    same here, nothing strange on server (no multisite and no subdomain or subfolder)
    theme installed is Uncode.
    here is the error i get in console, which makes the “connect account” in step 1 unclickable:

    [Error] TypeError: e.indexOf is not a function. (In ‘e.indexOf(” “)’, ‘e.indexOf’ is undefined)
    (funzione anonima) (jquery.min.js:2:84940)
    (funzione anonima) (mailchimp-woocommerce-admin.js:4)
    Codice globale (mailchimp-woocommerce-admin.js:670)
    [Error] TypeError: null is not an object (evaluating ‘o.nextSibling’)
    (funzione anonima) (index.js:2:119214)
    (funzione anonima) (index.js:2:119449)
    a (index.js:2:1263)
    (funzione anonima) (index.js:2:3981)
    Codice globale (index.js:2:3991)

    Plugin Author ryanhungate

    (@ryanhungate)

    @marcods would you be open to sending a temporary admin request to ryan (at) vextras.com so I can try to fix this for you? We’re just not seeing the same errors no matter how much we try. If I could go in and edit the plugin on your server I should be able to figure out where and why this is happening.

    @ryanhungate sure. i’ll write you an email as soon as i solve another issue
    thanks!
    best,
    Marco

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.