WordPress.org

Forums

No plugin menu and Error 310 (29 posts)

  1. zedrino
    Member
    Posted 3 years ago #

    Hello, I just upgrade WordPress MU to 3.2.1.
    First I thought everything was working great then I noticed I don't have the Sub Menu in
    - Plugins: can't install, look for new etc, just activate or deactivate like in wordpress.com.

    Also I can't access : Update Network link or the Howdy Admin - Network Admin. click on it give me :

    Erreur 310 (net::ERR_TOO_MANY_REDIRECTS)...

    Thank you for any help

  2. zedrino
    Member
    Posted 3 years ago #

    Here is a txt of the

    wp.config

    and the

    htaccess.

    thank you.

  3. I just upgrade WordPress MU to 3.2.1.

    Were you actually on wordpress mu?
    (actually I can tell from the config file you were)

    Did you go straight to the latest version fro 2.9.2? If so, that's the problem. You were back far enough you needed to upgrade incrementally.

    also, yu left your salts in that file so I'm disabling the link.

  4. zedrino
    Member
    Posted 3 years ago #

    Ok sorry for the salts (didn't realize this was confidential too) and thanks for answering,

    In fact following your and Ipstenu advise I upgraded from MU 2.9.1 to WP 3.0 manually then... yes I have to admit to the 3.2.1...

    Then now that I did this what do you think I can do to repair all this ?
    Should I export the BDD to a clean and fresh install of WP 3.2.1 ?

    thank you for your help.

    After Andrea_R warning I show back the wp-config if this can help to find a solution...

  5. No, you have to sort out why you can;t get in to Network admin.

    Look on the server. Go to /wp-admin/network/ Look at the permissions and ownership of that folder. It should be the same as the rest of the install.

  6. zedrino
    Member
    Posted 3 years ago #

    Thanks Andrea_r,
    well /network/ is 755 like others and files are 644.
    aouch...

  7. Try changing your htaccess to the current one for WP MultiSite http://codex.wordpress.org/Create_A_Network#.htaccess_and_Mod_Rewrite

  8. zedrino
    Member
    Posted 3 years ago #

    Hi Ipstenu

    I changed the htaccess to this

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress

    Also I have deleted cookies but

    the admin is still the same;
    no Plugin menu
    no access to Network Admin
    , result; Error 310 (net::ERR_TOO_MANY_REDIRECTS)

    WordPress is in the root and have subdomains.

    Do you have an other idea please ? thank you

  9. getting access to network admin will fix the plugins menu issue.

  10. no access to Network Admin, result; Error 310 (net::ERR_TOO_MANY_REDIRECTS)

    Too many redirects. That's usually a mismatch between http://www.domain.com and domain.com on your site - The DB and the wp-config.php have to be the same.

  11. zedrino
    Member
    Posted 3 years ago #

    On the wp_blogs table:

    Blog_id site_id domain
    1 1 bluegreenbelize.com
    and a list of all the blogs and subdomains... without www.

    On the wp-config.php:

    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'bluegreenbelize.com' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOGID_CURRENT_SITE', '1' );

    Should I check somewhere else ? thanks for your serious help.

  12. You also have these?

    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
  13. zedrino
    Member
    Posted 3 years ago #

    No I didn't...
    then
    I added the 3 lines in the wp-config (before authentification keys)
    - the blog is unaccessible with problem to connect to the database.

    Where should I put them ?

    I removed them, back to "normal". Thanks Ipstenu, please more suggestions.... you must be close to find the problem !

    Access to the wp-config (txt format) here.

  14. zedrino
    Member
    Posted 3 years ago #

    Also something new:

    In the Top of the admin screen there is the menu with Updates 26.
    Same problem, Error 310.

    Andrea_r is right, this Updateslink points to http://mysite.com/wp-admin/network/update-core.php.

    It must be a problem with the whole network folder or files or config.... don't understand...

  15. In the Top of the admin screen there is the menu with Updates 26.

    The 26 means you have 26 plugins & themes needing updating is all.

    Tell your host you cannot access that folder.

  16. zedrino
    Member
    Posted 3 years ago #

    Hi I'm back

    I tried to have some response from the host but nothing came in.

    Then I keep going and I find this post.

    I have a _transient_random_seed on several wp_xx_options tabs not all of them.

    Start to delete one but would better to ask you first if this tell you something...

    thanks

  17. transient feeds aren't the issue. Though I don't know what is. The feeds are just cached rss data from the back end of your site. They're okay.

  18. zedrino
    Member
    Posted 3 years ago #

    I deleted the cookies and try again directly on the blog 17 (where I have deleted the transient_random_seed entry in the tab) same problem when I click on Network Admin...

    Thanks ipstenu

    Something I don't understand:
    if
    the blog xx is named "example" under mywp.com (WP multi site),
    the Network admin doesn't link to http://example.mywp.com/wp-admin/network/upgrade.php
    but there

    http://mywp.com/wp-admin/network/upgrade.php

    you think that's correct ?

    thanks again

  19. Don't use <li> tags outside of <ol> or <ul> on the forums, You'll BREAK things :)

    Your network admin is ALWAYS off the main site, NEVER off a subsite. That's expected.

  20. zedrino
    Member
    Posted 3 years ago #

    Should I just make a new fresh htaccess with the www redirection thing (as you said at the beginning) ? Actual htaccess doesn't have this specified...
    more thanks

  21. zedrino
    Member
    Posted 3 years ago #

    here is a phpinfo from the /network/ folder .

  22. zedrino
    Member
    Posted 3 years ago #

    Ok gentlemen, I'm back with the solution,
    please don't tell me again I did something wrong ok,

    I just did what Amit Cohen did,

    replace the original admin.php code

    and make it more simpler....

    <?php
    /**
     * WordPress Network Administration Bootstrap
     *
     * @package WordPress
     * @subpackage Multisite
     * @since 3.1.0
     */
    
    define( 'WP_NETWORK_ADMIN', TRUE );
    
    /** Load WordPress Administration Bootstrap */
    require_once( dirname( dirname( __FILE__ ) ) . '/admin.php' );
    
    if ( ! is_multisite() )
    	wp_die( __( 'Multisite support is not enabled.' ) );
    
    if ( ! is_main_site() ) {
    wp_redirect( network_admin_url() );
    exit;
    }
    ?>

    Yes that's poetry, it sounds just perfect, nothing more nothing less, just right ! Right ?

    take it easy,
    thanks for all

  23. FYI we never ever advocate editing core files. This is a bad way to do things.

  24. zedrino
    Member
    Posted 3 years ago #

    Here we go, something bad again !!!

    you know what, I have tried almost everything I found, nothing worked, nothing till this code... then what ?

  25. I would try a fresh install in a different folder, just to see if you can recreate the problem. Because ... we can't :/

  26. kbeatt
    Member
    Posted 3 years ago #

    I am having the same problem as zedrino. I upgraded my installation today and I have no access to the network admin link and my plugins page has no plugins available for activation or deactivation although there are certainly plugins activated.

  27. kbeatt
    Member
    Posted 3 years ago #

    Nevermind.

    I discovered I was using the old blue-network plugin for highlighting network plugins in blue. That was in my mu-plugins folder. I removed it and everything came up the way it was supposed to.

  28. zedrino
    Member
    Posted 3 years ago #

    I upgraded to the 3.3 and of course the problem is back.
    Deleted the mu-plugin folder and still have no access to Update Network and got a

    Error 310 (net::ERR_TOO_MANY_REDIRECTS).

  29. zedrino
    Member
    Posted 3 years ago #

    admin.php is not working for this version anymore.

    Now will probably have to do a fresh install on a new folder, as suggested by Ipstenu but still try to find an alternative to it.

Topic Closed

This topic has been closed to new replies.

About this Topic