WordPress.org

Support

Support » Plugins and Hacks » [Resolved] No placemarks on theme Raindrops

[Resolved] No placemarks on theme Raindrops

  • I saw a similar question in this forum, but it was with no response.
    I saw your answer:

    Do the placemarks show up when using TwentyTen? yes
    Do the latitude and longitude show up on Edit Placemark page? yes
    What version of the plugin are you using? last version
    Can you tell me the URL of site so I can take a look at it? is in local

    It looks like Bizco includes a Google Map of their own, which could potentially cause a conflict, but I’ll know more once I can see your site.
    I use raindrops and it has the same problem.

    wait your response

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Author Ian Dunn

    @iandunn

    Thanks for the info Orazio. I’ll do some testing with that theme and see if I can find the problem. There are a few higher priority bugs, though, so it’ll probably be a few weeks before I can get to this.

    Thanks a lot ian for this plugin. I’ll wait for the edit. Good Work!

    I’m having the same problem as Orazio10 is describing above… The Maps works in TwentyTen but as soon as I activate Vanilla from Yootheme it stops…

    Is there anything in the source code of the theme that should be changed in order to get it to work? I come from a Joomla environment and can’t really see why plugins stops working between different themes.

    Plugin Author Ian Dunn

    @iandunn

    Thanks for letting me know jesperlofgren, I’ll add that to my list of themes to test. Can you post the URL to your site so I can take a look at it? Also, please describe what happens when “it stops.” Do you get any error messages? Does the map show up but not the placemarks, or does the map not show up at all?

    Sorry for being a bit unclear. The map shows up but no placemarks. The strange part is that it worked earlier, until I updated your plugin. I hadthe same problem earlier wit the same theme but all of a sudden it worked just fine. Do youhave any good tricks up your sleeve?

    The site is on localhost at the moment.

    Plugin Author Ian Dunn

    @iandunn

    Hmm, it’s hard to say without being able to look at it. I am going to be reworking a lot of the JavaScript that’s been causing people problems in the next release, though, so there’s a good chance that might fix it.

    If you’re running Firefox with the Firebug extension, look at the console and let me know if there are any errors showing up (even if they’re coming from another plugin or the theme).

    Firebug isn’t showing any errors at all… I also tried to inactivate all javascripts in the theme but that didn’t turn out good, instead it wasn’t loading the map at all… I guess the plugin needs the JQuery-script… I give that method another try later.

    But logically the problem must be caused by one or two js-files loaded by the Vanilla theme as with the TwentyEleven theme the map is loading correctly…

    I had the same problem with a theme called: Parquetry 1.1
    I ran the firebug error console and

    bgmp_createMarker(): Not all of the required data was passed in.
    in jquery (line 18)

    /wp-admin/admin-ajax.php

    have you seen anything like this?

    I checked my site with Safaris error console and it also says:

    bgmp_createMarker(): Not all of the required data was passed in.
    wp-content/plugins/basic-google-maps-placemarks/functions.js?ver=1.2.1:146

    If you read the source code it says:
    if( latitude == ” || longitude == ” || icon == null )
    {
    if( window.console )
    console.log(‘bgmp_createMarker(): Not all of the required data was passed in.’);
    return false;
    }

    I find no mentions in the database about the icon. I also saw now that I can’t assign a icon to a placemark… That link has disappeared from the editing page…

    Sorry for flooding.

    When switching to TwentyEleven I can set a featured image to my Placemarks… If I switch to Vanilla I no longer have that option. That’s probably what’s causing the problem in the first place… Need to digg deeper.

    Plugin Author Ian Dunn

    @iandunn

    Hey nohler, I have seen that before and I’m looking into what’s causing it.

    Jesper, thanks for digging into it. I think the fact that the theme doesn’t support featured images is probably part of the problem. I’ll work on fixing that in the next release or two.

    The theme I’m working with: Parquetry 1.1 – DOES support featured images.

    I’ve been digging also and it has a slew of sub style sheets which have an, as yet, unidentified purpose.

    I think i may just customize Twentyeleven, since it works with your code just fine.

    Perhaps there is some deprecated coding or styling in Parquetry 1.1

    Hi,

    Adding this to the themes functions.php solved my problem:
    add_theme_support( ‘post-thumbnails’ );

    /Jesper

    Plugin Author Ian Dunn

    @iandunn

    Jesper – That’s weird because the plugin is already doing that on the admin side, but maybe it has to run on the front end too, or maybe it doesn’t work right when a plugin tries to do it instead of the theme. I’ll look into it more.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] No placemarks on theme Raindrops’ is closed to new replies.