Support » Plugin: BMo Expo - a WordPress and NextGEN Gallery plugin » "[No pictures in galley]" – error

  • Resolved pressuser79


    I’m receiving an error message that says “[No pictures in galley]” when I try to view the gallery in a page. NextGEN 2.0.31 is installed and I am using version 1.0.1 of BMo Expo.

    Everything appears to be setup correctly. I have verified the particular NextGEN gallery has images & thumbnails; BMo sees the correct gallery when I try to insert it via the button on the page editor toolbar.

    The shortcode that is inserted into the page is:

    [BMo_scrollGallery id=7 sG_thumbPosition=bottom sG_images=1 duration=slow gallery_width=600 gallery_height=400 thumbs_width=100 thumbs_height=100 sG_caption=1 sG_start=1 sG_loop=1 sG_loopThumbs=1 sG_clickable=1 sG_opacity=40 sG_area=200 sG_scrollSpeed=2 sG_autoScroll=1 sG_aS_stopOnOver=1 sG_diashowDelay=0 sG_followImages=1 sG_responsive=1 ]

    7 is the correct scrollGallery as well. Any thoughts?

    “galley” in the error message is misspelled as well.

    Your plugin looks very promising!

Viewing 5 replies - 1 through 5 (of 5 total)
  • I had this problem too, and after digging around in the code and debugging elements, I realized that this is something to do with the metadata of the images in the gallery. (this was only happening to me whenever I changed something in the gallery like updating the thumbnails or something).

    Try going to the gallery in Gallery->Manage Galleries and choosing “import metadata” for the galleries that aren’t working. That fixed it for me.



    Thank you grifmo. This did appear to give me some help. I did what you suggested and I downloaded the new 1.0.2 version. I tried a couple times and it didn’t work. Then I realized I didn’t have the GD library installed. Since NextGEN really wants to have that library installed I figured it was worth figuring out how to install. After successfully getting the GD library installed, I was still getting the
    “[No pictures in galley]” error so I created a new gallery and tried your suggestion and this time it worked!

    I’m not sure if the GD library had anything to do with it or not, but if anyone needs to install it on their server try:
    apt-get install php5-gd
    or maybe
    yum install php-gd

    You’ll probably need to reboot after installing so GD can load properly.

    Plugin Author Benedikt Mo



    Hopefully there is an easy solution to this but my query is that I am having the same problem as the above but there a knock on effect.

    The solution of importing meta-data into each gallery works except that if I later make changes to the gallery, it then re-creates the problem again and i have to re-import the metadata again.

    The importing of meta-data, also throws out any of the captions I’ve added to the image and replaces them with the information in the meta-data which means I can’t use the ‘show captions’ options and also restricts the amount of optimising I can do to the images.

    Is there any other work around beside the importing meta-data each time?

    I recently updated to wordpress 3.9, I’m not sure if this is what is causing the issue as I didn’t have to import the meta data before.

    Same thing here. Are you working on a solution or should I start looking for another plugin that does the job?

    Thanks, I hope a solution will be found soon because in general I like your work.


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘"[No pictures in galley]" – error’ is closed to new replies.