Support » Plugins and Hacks » No photos are appearing just the loading animation

No photos are appearing just the loading animation

  • Hi,

    I’ve repeated the process twice already with the authentication of the instagram application but it still doesn’t work.

    Tried already with the default WordPress 2013 theme but still no go. It just a loading GIF that appears on the page.

    What’s the possible reason for this?


Viewing 13 replies - 1 through 13 (of 13 total)
  • anyone?



    I encountered the same issue on another site. I think it’s a caching issue. We also use WP-Super-Cache for managing caching of our entire site so I’m not 100% certian yet which is at fault. Whenever I force flush WP-Super-Cache, our instagram feed comes back. If I figure it out, I’ll post an update.



    For me, it looks like my WP install can’t create a needed cache folder:
    ./wp-content/plugins/easy-instagram/cache. I found this error message on the admin page for the plugin (Dashboard > Settings > easy-instagram).

    Once I created that /cache folder, this plugin worked. I’m not sure why easy-instagram wasn’t able to create this folder on its own, but there you go.



    To the plugin Author, I would suggest the following:

    1. Provide a direct link from the plugin on the installed plugins page to the */wp-admin/options-general.php?page=easy-instagram page. I was unaware of this page at first and we’ve used other plugins (Akismet for one) that do this.
    2. Provide a clearer message than “folder */easy-instagram/cache is not writable”. A non-existant folder should be easy enough to detect and report back through the admin.
    Plugin Author VeloMedia


    Hi all!

    For the next release we are working on the following new features:

    –Configurable cache directory, to help with some server configurations where directories inside wp-content/plugins are not writable.

    –Separate error messages for separate cases of “cannot create folder/nonexistent folder” and “cannot write to folder”.

    –Link to the plugin settings page on the installed plugins page.

    In the meantime, for anyone having issues with the creation of the “cache” folder inside wp-content/plugins/easy-instagram, if you have the proper access please try adjusting the folder permissions.

    Thank you,

    I’ve got the same issue mentioned above, spinning loading images, but no content. I have a wordpress installation where easy instagram works perfectly, and another where it doesn’t work. I looked at the cache folders and they are both there, same permissions, but one folder is empty. What could be the problem? What can I do?


    I started having the same issue a couple of weeks ago, with no backend changes on my end


    the cache folder is 755, which should be fine; I’m wary about changing the permissions to 777. Any thoughts?

    Ok, well, logging out of Instragram from the Easy-Instragram settings page and logging back in appears to have fixed the problem. Weird.

    Glad it’s working for you…

    I tried logging out and then back in, no dice.. still get the spinning loading image, empty cache folder (755). Waited 10 minutes in case it was a caching issue, still nothing. Anyone else have luck?



    A quick follow up to my earlier comments. I encountered this problem again, and after some additional digging found how to tell our main caching plugin, WP-Super-Cache, how to ignore easy-instagram’s cache folder.

    Settings > advanced tab. 2/3rds of the way down the page, you can configure URI patterns for wp-super-cache to ignore. I added “easy-instagram\cache\*” to the list of URI patterns to ignore, refreshed, and my instagram feed reappeared.

    Thanks Cameron, still having problems here. We did have wp-super-cache installed initially. I disabled it when I first started all this. I enabled it and made the change you suggested. I even deactivated wp-super-cache altogether and nothing, still doesn’t work… I also deleted the cache folder, recreated it, and nothing. Is there a way to print out any errors that might be happening? thanks….



    We’re still having problems too which makes me think that wp-super-cache might not have been (entirely) at fault. I’m contemplating trying to debug the ajax call next. :/

    Plugin Author VeloMedia


    Thanks for continuing to follow-up, Cameron. We’re in the process of testing interaction with WP Super Cache as part of our next release, and we’re taking your comments into account. Will report back here if we find a possible solution.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘No photos are appearing just the loading animation’ is closed to new replies.