• Resolved Don BSN

    (@don-bsn)


    I just updated both contact form 7 and send as pdf.
    Currenlty no pdf is attached to the emails.
    What do I need to do to correct this.
    Everything was working yesterday prior to the upgrade.

Viewing 15 replies - 1 through 15 (of 20 total)
  • mosertronik

    (@mosertronik)

    Jep, just got the same problem.
    Actually I found no solution.
    Maybe someone got an idea?

    inforce

    (@inforce)

    I do have the same problem. Hope support will resolve this issue. Because I didn’t find any solution.

    artyus

    (@artyus)

    I confirm the problem exists.

    ADD: Re-saving the PDF settings for the form does not change the situation (this method worked before).

    • This reply was modified 2 years ago by artyus.
    Rafael

    (@jordh)

    I am having the same issue. My debug.log file contains the following lines:

    [22-Jun-2022 ] UPLODA: /[...]/wp-content/uploads/sendpdfcf7_uploads
    [22-Jun-2022 ] UPLODA: /[...]/wp-content/uploads/sendpdfcf7_uploads
    [22-Jun-2022 ] PHP Warning:  copy() expects at least 2 parameters, 1 given in /[...]/wp-content/plugins/send-pdf-for-contact-form-7/classes/send-pdf.php on line 1038
    [22-Jun-2022 ] UPLODA: /[...]/wp-content/uploads/sendpdfcf7_uploads
    [22-Jun-2022 ] UPLODA: /[...]/wp-content/uploads/sendpdfcf7_uploads
    [22-Jun-2022 ] PHP Notice:  Das Anhängen einer Datei ist fehlgeschlagen. /[...]/wp-content/uploads/sendpdfcf7_uploads/4195/Supportanfrage.pdf befindet sich nicht im zulässigen Verzeichnis. in /[...]/wp-content/plugins/contact-form-7/includes/mail.php on line 147

    I hope that this helps with identifying the issue.

    betisimo76

    (@betisimo76)

    Hello,

    I have the same problem. My PDF was sent successfully but now it is not attached to the email.

    Thank you

    betisimo76

    (@betisimo76)

    Hello again,

    I have tried to download to version 0.9.1 and the plugin works normally, therefore, it must be some modification in this latest version (in case it helps).

    Thanks.

    • This reply was modified 2 years ago by betisimo76.
    Thread Starter Don BSN

    (@don-bsn)

    Yep – I reverted back and it is working.

    patricksdg

    (@patricksdg)

    I have the same issue? How do you revert it back? Does anyone have the previous code?

    inforce

    (@inforce)

    How to reverted back to version 0.9.1 ? I cant find the zip file with the version 0.9.1 ?

    betisimo76

    (@betisimo76)

    Hi again,

    I have installed the WP Rollback plugin, which allows you to downgrade any plugin you have installed and belongs to the wordpress repository.
    Install it, go to the plugin that is causing problems and you will have the option to “roll back”.

    I hope it helps until we have a solution from support.

    mosertronik

    (@mosertronik)

    Hello,

    I got the version 0.9.1 from an backup.
    You can download it here: https://cloud.lus.one/s/WMEbYiRc63dLXYS

    Also tested it, it worked with this version. So it must be an error in the version 0.9.2

    • This reply was modified 2 years ago by mosertronik. Reason: added tested info
    artyus

    (@artyus)

    How to reverted back to version 0.9.1 ? I cant find the zip file with the version 0.9.1 ?

    Without any other plugins, standard way:

    1. Please use “Advanced View” link on right upper side on plugin page.
    2. After on page bottom select needed version for downloading.

    I roll it back to version 0.9.1, and it works again. With version 0.9.2 PDF will not be attached to the e-mail, means version 0.9.2 has a bug. I hope the plugin support does issue an update to this bug soon.

    We’re having the same issue, but I don’t want to role back because this recent release contained security patches and the dev notes do not say what the security issues were that were patched.

    I looked in the code and found the error.
    On line 1038 and line 1080 there is the copy function. There was added an esc_url() but unfortunately the ) was on the wrong place.

    This is what it is (on line 1038):
    copy(esc_url($createDirectory.'/'.$nameOfPdf.'-'.sanitize_text_field($_SESSION['pdf_uniqueid']).'.pdf', $createDirectory.'/'.$nameOfPdf.'.pdf'));

    This is what it should be:
    copy(esc_url($createDirectory.'/'.$nameOfPdf.'-'.sanitize_text_field($_SESSION['pdf_uniqueid']).'.pdf'), $createDirectory.'/'.$nameOfPdf.'.pdf');

    I made an fix for it and testet it, it’s working like a charm.
    You can download it here: https://cloud.lus.one/s/Gwi9fCkNwSnid66

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘No PDF Attachement’ is closed to new replies.