Support » How-To and Troubleshooting » [Resolved] No pagination on 2.3.2?

[Resolved] No pagination on 2.3.2?

  • I’ve noticed that the page navigation does not appear on the index page of my site (www.drewvogel.com) since I upgraded to 2.3.2.

    However, if I SEARCH for a term (say, “Recipe”) from the index page’s search box, the page navigation appears on the results page. But it doesn’t appear anywhere else (front page, categories, etc).

    I thought it might be my theme (Tarski) but with Ben’s help have determined that it is not the theme’s issue (this issue occurs with any WP theme).

    I am not sure how to proceed — where to look for the solution — and would appreciate any guidance.

Viewing 15 replies - 1 through 15 (of 20 total)
  • I can see your Pages list both in the top horizontal menu bar and in the sidebar.

    Thanks for the reply, Moshu… I don’t think I was clear enough in my original message.

    If you visit http://www.drewvogel.com/page/2?s=recipe , see the “« Previous results § More results »” at the bottom of the page.

    Something similar used to appear at the bottom of the front page (and, in fact, EVERY page where appropriate) of my site — http://www.drewvogel.com . It doesn’t anymore since upgrading to 2.3.2.

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Do you have the next_posts_link and previous_posts_link calls in your theme’s index.php file?

    A perfectly reasonable question that I should have answered in my orignal post…

    I do have those entries (and the whole kitchen sink) in my theme’s index.php file:

    <?php include(TEMPLATEPATH.'/loop.php'); ?>
    <?php wp_pagebar(); ?>
    <?php previous_posts_link(); ?> <?php next_posts_link(); ?>
    <?php posts_nav_link(); ?>
                            <?php tarski_posts_nav_link(); ?>

    Does my reply make sense? I am still stumped…

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Got anything unusual in the loop.php file? A query_posts() call, perhaps?


    Thank you for your reply. I appreciate it.

    Line 1 of loop.php (completely bone-stock Tarski theme 2.0.5) contains:

    <?php if(!is_home() && !get_tarski_option('use_pages')) { $posts = query_posts($query_string . '&nopaging=1'); } ?>

    Is that part of the issue? (I am no coder, so am not sure how to proceed.)

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    Well, that seems like it’s obviously your problem. Why are you setting nopaging to 1? As its name implies, that turns off the paging.

    I don’t know what “Tarski” is doing, but that suggests to me that it’s got some kind of setting somewhere to turn that on or off, since it’s getting a “use_pages” option…

    My advice: Use a normal theme.

    From the discussion on the Tarski forum, my question:

    I take it the older/newer posts navigation works ok on other themes?

    And the answer…

    Hrm. Just tested it with WordPress Default Theme 1.6 and had the same problem — no display at the bottom of the front page, but if I searched for a term (say, “Recipe”), the page navigation appears on the results page.

    So the problem isn’t Tarski. It’s my site…

    Moderator Samuel Wood (Otto)


    WordPress.org Tech Dude

    No, it’s not WordPress. I just tested on my own site (running 2.3.3), and the pagination works correctly and just as expected with both my theme and the default theme.

    I use this code:

    <p style="text-align:center"><?php next_posts_link('&laquo; Previous Entries') ?> <?php previous_posts_link('Next Entries &raquo;') ?>

    And as you can see on the bottom of my main page, the previous and next entries links show up just fine.

    That nopaging variable is far more likely to be the culprit. I mean, that is specifically what it does, it disables the paging. With nopaging set to 1, you won’t get those links. That’s sorta the whole point of it.

    If he’s trying it with the default theme then that code isn’t going to have any effect, since it’s in a totally different theme.

    Obviously I can’t corroborate that he has the relevant option enabled, but since pagination works just fine for me on Tarski when it is, this seems to indicate that something else is going on.

    What suggestions about where to look can the experts on this site offer? I’m happy to poke around in code and provide samples, etc. I’d really like to get this issue diagnosed and fixed!

    Anyone? Anyone?!



    Why isn’t anyone helping me?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] No pagination on 2.3.2?’ is closed to new replies.