Support » Plugin: BookPress - For Book Authors » No pagination

  • Resolved jenniferfelton

    (@jenniferfelton)


    I added the book to my sidebar using the widget, and there is no way to advance to the next page.

    I tried uninstalling all other plugins and switching to the Twenty-Twenty theme but it was the same result. So it’s not a theme or plugin interfering with the BookPress plugin.

    I really like the idea behind the plugin, and wish I could get it to work correctly.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Oh, and this piece of code appears with my cover, as well: class=”wp-block-image”> is-resized”>

    And the cover only seems to appear at random. Sometimes when I click to read, it shows up – while other times it doesn’t. Appears more so when using Edge than Firefox or Chrome.

    And the text gets cut off at the bottom.

    I sort of figured it out, but it’s still problematic.

    It doesn’t display correctly at 100%. You have to zoom out to 80% in order to see the entire space – the entire page and the pagination options.

    This is highly problematic, as we can’t be expecting people who are visiting our sites to fiddle around with their zoom to see if it works.

    They will assume, like we all are, that there’s something wrong with the site or plugin.

    And there is code all over the place within my document (especially where pictures are placed – and I have a lot of them).

    Plugin Author Irfan Qasim

    (@iqasim)

    Hi,

    Let me check then get back to you.

    kind Regards
    irfan Qasim

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Hi
    The plugin is not designed to offer zoom or to change size on pages. Also it’s not designed for the Gutenburg blocks so that might be why you are getting the error – please install the Classic wordpress plugin and run that on the pages where you want to display books.

    Pagination needs to be switched on and off and you can find more here on the ‘Configure your main book settings’ section here https://www.bookpress.net/docs/bookpress/1-0-getting-started/1-2-adding-a-book/

    Everything works fine, except that to see the entire space, you have to set your browser’s zoom to less than 100%. 100% is the default for which most people view websites, so when they open the book and they see things are cut off, no one is going to think that they just need to adjust their browser’s zoom. And Safari on iPad there is no way to zoom in and out.

    I have pagination turned on, to show the numbers at the bottom. They’re there, you just can’t see them unless you adjust your browser to less than 100%.

    Whether I use the classic editor or not, it displays correctly in shortcodes in pages. But from the sidebar, it doesn’t. You have to change your browser’s settings to less than 100% zoom.

    nevermind — the post below wasn’t posting as a new topic, but it actually did. I just had to refresh a few times for it to show…

    ——-

    I’m also having an images problem – I tried to create a new post, but twice it told me the page couldn’t be found.

    When I have an image, either as the cover or within the content body, code appears either overlaid in the image or before the image. For example, within the cover image is the following code: is-style-default”>

    Is there a way to get rid of this? I plan to do something that will have A LOT of images, and having this code appear will mean I can’t use this plugin for one of the things I intended.

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Please can you post a link to the pages showing the issues?

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Okay – I see you started a new topic and added a link so will continue the images discussion to that.

    The page is a set size and is fully visible in my screen at 100% zoom – are you using a small screen by any chance?

    jenniferfelton

    (@jenniferfelton)

    http://www.magikandmayhem.com/index.php/book/eternal-beginnings-patreon/

    My website is http://www.magkandmayhem.com. On the left sidebar I added the widget, which is how I originally intended to display the books. But when you click on it, it’s too blown up at 100%, and I have to zoom out of my screen. (I’ve tried it with Edge, Chrome, and Firefox. I’ve had varying results from the cover not showing at all and just having the code – which is addressed in another post, to the cover and the code, but always it’s too zoomed in.)

    I do have it now within a page and added to the menu, and there it shows fine. So I’m not sure what the issue is with the widget.

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Hi

    Thanks for the link. I can see the code snippet and the pagination shows partially at the bottom of the screen – can you test for a theme conflict? Simply switch to a standard WordPress theme and see if the issue resolves? Let me know what happens.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘No pagination’ is closed to new replies.