Support » Fixing WordPress » No pages loading, not even wp-admin, get error message

  • tudoindia

    (@tudoindia)


    Hi all,

    Any help would be immensely appreciated right now, because I just realized that nothing on my site is working, not even the wp-admin… every page returns this error message:

    Warning: require(/home2/tudoindia/public_html/wp-includes/load.php): failed to open stream: No such file or directory in /home2/tudoindia/public_html/wp-settings.php on line 21

    Fatal error: require(): Failed opening required ‘/home2/tudoindia/public_html/wp-includes/load.php’ (include_path=’.:/opt/php54/lib/php’) in /home2/tudoindia/public_html/wp-settings.php on line 21

    The strange thing I that I have done absolutely NOTHING on my site in the last 1.5 months – no new plugins installed, etc. I have literally only been logging in to check my stats… and today the stats page gave this error (as did every other page I checked afterwards). Based on Google analytics, my traffic suddenly stopped about 8 hours ago, but I’ve done absolutely nothing on the site recently that could have caused this.

    In any case, does anyone have any idea what I can do to fix the problem?

    Thanks,
    Alex

Viewing 8 replies - 1 through 8 (of 8 total)
  • Randy Sandberg

    (@randywsandberg)

    What version of WordPress are you running?

    tudoindia

    (@tudoindia)

    I honestly can’t say for sure. I installed the most current version when I created the site in August, and I believe it has automatically updated a few times since then.

    Randy Sandberg

    (@randywsandberg)

    And when was the last time your site was functioning properly?

    tudoindia

    (@tudoindia)

    As I mentioned, according to Google Analytics it was getting its usual traffic until about 8 hours ago, then abruptly stopped.

    Randy Sandberg

    (@randywsandberg)

    My guess, given what you said above about your site being automatically updated, is that there’s some kind of 3rd party incompatibility with the latest version of WordPress (i.e., version 4.5). Thus you might be able to quickly get your site back up again by temporarily disabling ALL your plugins and switching back to the default (i.e., Twenty series) theme.

    Here’s how to disable your plugins without needing to log in to your site:
    https://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    And here’s how to switch back to a default Twenty series theme with needing to log in to your site:
    http://www.inmotionhosting.com/support/edu/wordpress/change-theme-in-db

    Hope this helps! 🙂

    Randy Sandberg

    (@randywsandberg)

    Oh, eight hours ago! Yikes. Hmm, WordPress 4.5 debuted April 12th so maybe that’s not the case. Of course I am not quite sure how fast autoupdates occur but I’m not so sure now.

    I still though think it would be prudent to try to resolve your issue by temporarily disabling your plugins and switching back to the default theme.

    But, eight hours ago sounds very suspicious. Might I also suggest talking to your hosting provider just to rule out the issue isn’t something on their end.

    And, if needed, here are the instructions for manually updating WordPress via FTP:
    https://codex.wordpress.org/Updating_WordPress#Manual_Update

    tudoindia

    (@tudoindia)

    I think the site was hacked… I cannot follow the directions for deactivating plugins because there is no “active_plugins row” where there should be… and I cannot find the wp-contents directory either now… and my user login was also changed in the wp-users table… it looks like someone hacked into the site and deleted all these files… 🙁

    So now the obvious question is how I can can them back… though I guess I’ll have to check with my hosting company for that… :/

    Randy Sandberg

    (@randywsandberg)

    Yeah, that’s been in the back of mind too — given the “No such file or directory” error messages — but I was hoping for the best. 🙁

    Here’s a link for what to do if your WordPress site has been hacked:

    https://codex.wordpress.org/FAQ_My_site_was_hacked

    And then, once your site is back up, take a look here:

    http://codex.wordpress.org/Hardening_WordPress

    Hope this helps!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘No pages loading, not even wp-admin, get error message’ is closed to new replies.