Support » Plugin: SG Optimizer » No page is caching?

  • Resolved marknight

    (@marknight)


    Hi,

    According to the tutorial, in Supercacher Settings -> Test URLs for Cache Status I can detect if a url is cached. However, I tried almost all pages in this field, all says “the url is not cached”. I double checked all settings, all seems to be correct, there is really nothing looks suspicious. In this field, am I supposed to input url with or without the domain part? (I tired both, all says not cached.)

    What might be the reason causing this? Is there any other method to detect if a page is cached or not?

    Problem site is https://emergemagic.com

    Thank you.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    The issue is with your custom folder structure. We will see how we can handle this better. I will update this ticket once I have more information on that matter.

    Hi Hristo,

    Thanks for the reply.

    It would be very appreciated if you could explain it a little bit clearer:
    1. Is my site indeed being cached or not?
    2. By “custom folder structure”, what do you mean exactly? It is just a normal wordpress installed in subdirectory. Or, SG Optimizer works with wordpress installed under root of public_html only?

    I do have some other folders in public_html root, where I have some php scripts be called from within wordpress on certain pages. I did it this way particularly because I don’t want those folders be part of wordpress or be interfered by wordpress. I don’t have pages to those folders, they are not meant to be cached anyway. Are you indicating it is these folders that causing the issue? How?

    Thank you!

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    I’ve fixed it and now everything works 🙂 The site was incorrectly added witht the subfolder to che cPanel tool. Please check and verify everything is OK though.

    Hi Hristo,

    Thank you so much for the quick fix! WOW!
    The cache detection does give correct feedback now. And of course, site does feel lightening fast now!

    While your explanation DOES make me feel worried. Did I do something wrong with my folder structure? Could you explain a little bit more? Would future updates to plugins/themes cause some problem?

    You mentioned something wrong in cpanel, what is that? I just transferred over from Bluehost via SG’s free transfer service. I DO notice my site home url was modified after transfer. The issue you discovered in cpanel, could it be caused for similar reason?

    Thank you!

    Thank you!

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    There’s nothing wrong with your structure. Your site was added to the Dynamic Caching tool as emergemagic.com/emergemagic instead of emergemagic.com which was causing the issues.

    As for the difference nothing should have changed but your site speed. Please, check which parts are affected and see if you have enabled any frontend optimizations like css / js minification, etc.

    As I check further, the contact page (relative url /contact-us) is not caching somehow. I did not exclude it though. Can you please check it?

    Thank you.

    Ah, good to know nothing need to worry!

    New to this area, I do have js/css optimization tool installed and configured. Are you indicating these tools could destroy SG Optimizer’s caching functions? I carefully turned off similar function (like minify/combine …) in SG Optimizer already. I thought other tools would only cause some plugin stop working, shouldn’t influence SG Optimizer’s caching function. Correct?

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    No, but some plugins may generate CSS and JS that can break when combined for example. That’s why we have exclude interfaces. So I am wondering what exactly doesn’t work after the migration?

    I’m still testing. So far I can tell that the contact page (https://emergemagic.com/contact-us/) is not caching somehow. I double checked, it is not set for exclusion at all.

    And I checked in cpanel super cacher tool, in Dynamic Cache, the installation URL is displayed as http://emergemagic.com/emergemagic, I don’t know if this is related.

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    That page is excluded. Either in your exclusion list or there’s a cookie that we use to bypass. Rest of your pages are cached properly.

    Yes other pages seem to be cached correctly. As I’m sure it’s not in the exclusion list, I need to find what cookie (and better from which plugin) is blocking the caching. Any clue for that? This page is just a very simple page with a CF7 form. I have another page with a CF7 form too, that page is cached without any issue.

    So I just cleared all saved cookies in browser and retried, still, that page refuse to be cached…weird.

    I’ve tried purging all dynamic cache and Autoptimize cache (the only other plugin that is caching files), still no luck.

    Other than this weird page, everything else seems to be working fine. I love SG for its really short TTFB, 200ms vs 3s when was on Bluehost. Great!

    Plugin Author Hristo Pandjarov

    (@hristo-sg)

    SiteGround Representative

    Contact pages are excluded from the full page caching in order to prevent incorrect data from being sent. That’s expected behaviour and you should leave it like that 🙂

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.