WordPress.org

Support

Support » Plugins and Hacks » Duplicator » [Resolved] No package file found

[Resolved] No package file found

  • Hi there.

    I transferred files to subdomain folder, but when I tried to run the installer, I got the following message: System Requirements failed. When I click for more details, everything passes except for Root Directory which reads:
    [Pass] is Writable
    [Fail]Contains only one Zip file.
    Result = No package file found

    The package appears in the subdomain file. GoDaddy is my hosting provider, but I don’t think that is the issue since all the other system requirements passed.

    I deleted the first transfer of the package and uploaded a second time. I got the same message.

    Many thanks for any advice and direction you can provide.

    Keri

    http://wordpress.org/extend/plugins/duplicator/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle

    @corylamleorg

    The folder that the installer.php is in can only have one .zip file. If it doesn’t have any .zip files you will get this message and if you have more than one .zip file. So the only two files in the folder should be your installer.php and package.zip

    If your doing a manual extraction you still need to keep the package.zip file in the folder to finish processing…

    I also encountered this issue and have a workaround, although I suspect ultimately there is a small bug in the plugin (regardless I am very appreciative of this wonderful plugin).

    When I exported the package on my Mac (running WP on MAMP), the package was saved as a folder containing all the data files. The important thing to note is the output was not a zip file, therefore differs from the tutorial video. I think this is where the bug is.
    Then when I tried to import the package on my PC (running WP on WAMP), it also reported the same error:

    [Pass] is Writable
    [Fail]Contains only one Zip file.
    Result = No package file found

    The Import function actually expects the exported file as a zip file, not expanded as a folder.
    The workaround was to zip the content of the folder into a zip file, then leaving only the zip file and installer.php in the WP directory which allowed the import to complete successfully.

    Also note you must zip only the CONTENT of the exported folder, you must not include the parent folder itself. Otherwise you will get another error during the import process.

    Plugin Author Cory Lamle

    @corylamleorg

    Hey everyone,

    You both have good points. I’ll try to find a better workaround for this in the next few versions. Its on the todo list to look at…

    Thanks for the feedback!

    So I know this post has been marked as resolved, but I came upon the same problem and just checked, ran a search and only found one .zip file in my directory (the one from the package file). If it’s any help, aside from what people posted above is also says at the bottom “Note: Manual extraction still requires the package.zip file “

    Thanks!

    Plugin Author Cory Lamle

    @corylamleorg

    Hey Polk011,

    That is a good point… Thanks for the feedback!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] No package file found’ is closed to new replies.
Skip to toolbar