Support » Plugin: Video Embed & Thumbnail Generator » No output – thumbnail or video

  • Hi,

    First, thank you for a great plugin and working on it even you’re not a full time developer (as you mentioned in the description), for sharing this with the community and your active support on it.

    I installed ffmpeg and it’s dependencies on my CentOS 5.4 using a guide here: (found it from one of the support thread in your plugin).

    After installing, I finally saw the ffmpeg run in the command line when executing “/usr/local/bin/ffmpeg”

    I checked the settings of the plugin and made sure I’m using the correct path. Done!

    I proceed to create a new post and uploaded an mp4 file, I clicked Generate thumbnail and it presented 4 thumbnails. Then I clicked encode and it says “Encoding Mobile M4V. Encoding WEBM. Encoding OGV. (continues if window is closed)”, since the status bar is not moving and nothing is happening I just clicked insert into post. I saw a code auto generated, saved the post and checked the output.

    The output is just a post with blank page and a link to download the video file with label: “Right-click or ctrl-click this link to download.”. Nothing else!

    What am I missing?
    Thanks in advance!


Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Kyle Gilman


    Hi Joe, can you send me a link to a page that isn’t working? It’s most likely related to your template or you don’t have swfobject embedded. Does it work on a mobile device?

    Hi Kyle,

    Thanks for your response. The site is a private intranet link, is there a way I can send you the link privately?

    How do I verify my template supports playing the video and I have swfobject?

    I tried converting the video from standard avi to avi x264 + aac first before uploading and then the convert function of the plugin worked but still the video/thumbnail is not showing.

    I tried with an android device and on cross browsers of windows and mac, still no video or thumbnail in the post.

    Thanks a lot!



    Would still need fix on this, my videos are not showing at all. 🙁


    Plugin Author Kyle Gilman


    I don’t know how I could access a private intranet, but if you have a way to send me a link, you can send it to me at

    Did you resolve this issue. I am having similiar issues. I can generate thumbs (display and select). However, it is never saving them anywhere, get 404 when attempting to navigate to the actual thumbs. Then the encode button when clicked does nothing. Literally just sits there. Thoughts?

    Plugin Author Kyle Gilman


    joetheinsider wasn’t having any trouble generating thumbnails. The problem was in the plugin settings. swfobject was turned off, and the width and height had been cleared in the settings page, which led to some strange results. We fixed most of the settings, but updating to version 3.0 of the plugin and resetting the plugin to default values also solved most of the problems.

    @plundrigan, your issue doesn’t seem related. Are you using version 3.0 or later of the plugin? What version of WordPress are you running?

    I am on WP 3.5.1 and 3.1 of the plugin.

    Let me clarify it generate the thumbs while on the add media page. I can choose the thumb to use. Click Insert in Post. If I view the page the thumbnail is never displayed. So if I save the post and cut and paste the poster url to a new window. It generates a 404 error.

    Hope that is a little more clear.

    Plugin Author Kyle Gilman


    Yes, the problem is clear, but it’s going to be tough to diagnose. Do you have this problem with every video? Can you email me a link to one that’s giving you trouble?

    Hi plundrigan,

    Kyle is right, the correct settings and updates fixed the issue for me which now supports the latest WP version along with other improvements..

    After install the plugin is not working so I played around with the settings then I installed all required scripts in my server but I wasn’t able to return the plugin to the default settings that’s why I had the issue.

    For you, try making sure all required server scripts are installed and running.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘No output – thumbnail or video’ is closed to new replies.