Support » Plugin: Woocommerce Gift Wrapper » No Option showing up

  • Dear author,

    first of all, thank you for this great idea. Sadly I don’t get it work. I read the documentation and set up everything. Nevertheless, nothing happens. I tried to show the notification in all combinations but really nothing happens.

    I use Woodmart and Germanized. Do you have any idea to make it work or to check, where the problem might be?

    Thanks a lot and best regards,
    iRomeK

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Little Package

    (@littlepackage)

    Hi @iromek

    The first thing to try whenever you have WP problems is to deactivate all plugins and revert to a basic theme like twentytwenty or Storefront. In this manner you can detect conflicts pretty quickly and easily. Reactivate plugins one-by-one, starting with WooCommerce, then Gift Wrapper, and if things still work, keep going until you activate a plugin and it stops working. I suspect Germanized might not work with this plugin, but you’ll be able to confirm for us.

    Give it a try.

    • This reply was modified 7 months, 2 weeks ago by Little Package. Reason: spelling error
    Thread Starter iromek

    (@iromek)

    Hey,

    I fixed it. Not sure how.. I just deleted the first product and added a news one. Now the Button appears. Pretty nice. šŸ™‚

    Is there a way to make the picture appear anytime? For me the Pop-Up doesn’t load the image, by starting to scroll it appears. Or to add the option to any product as checkbox for example?

    Thank you very much!

    Best Regards,
    iRomeK

    • This reply was modified 7 months, 2 weeks ago by iromek.
    Plugin Author Little Package

    (@littlepackage)

    You’ll find those questions have already been asked here in this forum, and answered. Please search this forum first. Thank you!

    Thread Starter iromek

    (@iromek)

    could you be so kind to tell me question-link to the image loading problem?

    Thank you very much. šŸ™‚

    Plugin Author Little Package

    (@littlepackage)

    Please try the troubleshooting steps I started with when I first wrote to you. Those are steps to try EVERY time you have an issue with a WordPress plugin, or any WordPress problem. It’s very possible your theme or another plugin is causing the trouble with image loading.

    Plugin Author Little Package

    (@littlepackage)

    Hi @iromek I’m wondering how your troubleshooting went. Did you find the conflict? Here is more information (from WordPress) about troubleshooting: https://wordpress.org/support/topic/read-this-first-wordpress-5-6-master-list/#post-13760920 which can also help you with any other troubles in the future.

    Thread Starter iromek

    (@iromek)

    Hey,

    well I had an option for lazy loading images within my theme (Woodmart). By disabling this option the image appears. There is no way to bypass this image from the global settings. Well WP rocket has such an option, but this will cause other conflicts.

    In the end I disabled lazy loading over all. If there is a way to bypass this global function from the theme for your plugin, this would be awesome, cause no other plugin has trouble with this function by Woodmart.

    Best Regards,
    iRomeK

    Plugin Author Little Package

    (@littlepackage)

    @iromek A quick question: Do other plugins of yours also have pop-ups (modals)?

    Thread Starter iromek

    (@iromek)

    Hey,

    yes, Amazon Pay for example. But I can trigger a lot of things to pop-up with WP Bakery and there the images appear as well.

    Thank you

    Plugin Author Little Package

    (@littlepackage)

    Please also tell me,

    Which placement are you using for gift wrap? Before cart? After cart? etc.

    Look at the source code. What classes have been added to the gift wrap thumbnails’ tags?

    Thread Starter iromek

    (@iromek)

    I am using it before cart.
    This classes?
    .giftwrap_li .giftwrap_thumb, .wc-giftwrap .giftwrap_thumb

    Or did I look wrong?

    Plugin Author Little Package

    (@littlepackage)

    No you looked right, thank you. Can you please activate the plugin on your site so that I can see what is going on. Any further, and without being able to see the problem, there’s not much I can do.

    This is the first I’m hearing of this issue, so it could be unique to your setup… there’s a lot going on on that website.

    Thread Starter iromek

    (@iromek)

    Thank you. Sure, here is the link. Well the feature is not live yet, so please tell me when you checked it, that I can disable this feature.

    https://vilou.de/

    Thank you very much.

    I active “lazy load”now for showcase right?

    Plugin Author Little Package

    (@littlepackage)

    Yes, show me it broken so I can try to help to fix it. I will look now so please activate it.

    No promises for a fix right away. This could take a while as I have to prioritize paid work and my family.

    Thread Starter iromek

    (@iromek)

    I activated lazy load now.

    For me, the popup works, the image won’t appear.

    Thank you very much. Well I guess this really is a problem with the settings in Woodmart. This seems to be a very unique problem.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘No Option showing up’ is closed to new replies.