Support » Plugin: RediSearch » No option for password?

  • Resolved codeagency

    (@7grafix)


    Hello

    I’m trying redisearch for first time, but I can not connect to my redisearch setup while everything is configured properly.
    We use Docker container.

    When I use the redis plugin from Till Kruss to connect to redis container, everything works fine.
    When I try your plugin, it says it can not connect.
    But I wonder if this is possible because we can not set a password?
    All our containers have a password set.
    With the redis plugin, we can also set a password, or at least use the params in wp-config.php

    What about your redisearch plugin?
    Can we also set the password? I don’t see such field in the server settings in plugin.
    Can we also use params for redisearch plugin in wp-config.php? Do you have information for this to share?

    Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • seyntjim

    (@seyntjim)

    Same here. Even if my my setup has no password it still can’t connect. I checked my connection first using redis-cli command and it’s working just fine.

    codeagency

    (@7grafix)

    @seyntjim OK I just found something strange…
    I have 2 containers running:
    REDIS at port 6379 default
    Redisearch at port 6380

    In Redisearch plugin, I left port empty and now it says this:

    Redis server is running and RediSearch module is loaded! But your index not exist. This mean your site never been indexed or for some reasons, the index have been deleted. Please go to settings page and re-index your website.

    So now I’m trying to do this re-index thing, but the button is not responding at all….
    I don’t know but this plugin seems to be very buggy and unstable

    How is it possible it can connect to the service while it’s running on a different port when I’m not specifying it?

    codeagency

    (@7grafix)

    Here you can see a recording of the issue: https://www.useloom.com/share/9379013225914412a0a5315010fd5685

    I’m not sure, but I think that the plugin is hardcoded to stick to port 6379 which is now trying to connect to the redis service and not redisearch service.
    Otherwise I can’t explain how it can “find” the service with a blank port value.

    Plugin Author foadyousefi

    (@foadyousefi)

    Hi guys.

    Thank you very much for trying this plugin and reporting issue(s).

    For now, there is no password option available. But I will try to implement it as soon as I can.

    About the port, its using port number from settings entered by the user and only uses 6379 as the fallback in case no port is entered. But I will test this one also.

    codeagency

    (@7grafix)

    @foadyousefi

    Is it possible to have a fall back option via wp-config? Just like wp-redis plugin does?
    You can check it here: https://nl.wordpress.org/plugins/redis-cache/

    This is interesting for us, because we deploy plugins via WP-CLI and run a custom configuration via our cloud deployment platform.
    It allows us to “pre-configure” the wp-config with params for plugins, add custom WP settings like max memory etc…

    Plugin Author foadyousefi

    (@foadyousefi)

    @7grafix

    Why not. It sounds great. Will add it as well.

    codeagency

    (@7grafix)

    @foadyousefi

    Great!
    Can you give some kind of ETA when we can expect the next release with password fix?
    So I can have an idea when I can schedule this task back on my list.
    I’m eager to try redisearch as we are using Elasticsearch for many years and want to compare the both.

    Thanks!

    Plugin Author foadyousefi

    (@foadyousefi)

    @7grafix

    It’s hard to estimate how much effort this fix requires but will do my best to do it within this week until Friday.

    Plugin Author foadyousefi

    (@foadyousefi)

    @7grafix

    I’m working on this issue. There are some different ways/protocols of connecting to redis-server. Can you send me your settings in wp-config.php so redis-cache plugin is working? (Of course with dummy data.) Just want to see which way is working.

    Plugin Author foadyousefi

    (@foadyousefi)

    Password option added. Also server, port and password now can be set in wp-config.php like:

    define(‘WP_REDIS_HOST’, ‘127.0.0.1’);
    define(‘WP_REDIS_PORT’, ‘6379’);
    define(‘WP_REDIS_PASSWORD’, ‘your-password’);

    In my local env, tested with password protected redis-server. Everything working for me.

    Please update to version 0.2.3, test and let me know if there are still some issues.

    Plugin Author foadyousefi

    (@foadyousefi)

    @7grafix

    Regarding the issue when everything was OK and connection to redis-server was successful, but clicking on the index button was not indexing and does nothing, I checked and there was actually a bug. Its fixed in version 0.2.4

    Can you please test again and let me know.

    codeagency

    (@7grafix)

    @foadyousefi

    Unfortunately, it’ still not working for me.
    I have disabled the entire container image with redis and I only have redisearch Docker image running at the moment on port 6379

    But now both the regular wp-redis plugin is no longer working and redisearch plugin either.

    Can I sent you details on skype or can I show you in a teamviewer session or something we both know and understand what is going on.
    because we use a devops platform to manage containers and it’s configuration.

    From your last explanation, I understand that running the Redisearch Docker image already includes a “regular” Redis server?
    My understand was I needed both, as it also mention like this in your introduction:

    quote: 1. First, you will need to properly install and configure Redis and RediSearch.

    That gave impression we need both

    Plugin Author foadyousefi

    (@foadyousefi)

    @7grafix

    It sounds like docker container problem/issue.

    We can talk on slack. I’m @f.josef on wordpress.slack.

    codeagency

    (@7grafix)

    For anybody else:

    The issue comes from Docker image.
    The redisearch Docker image comes with NO default redis.conf
    You have to create that one first. After that, everything started working immediately

    I tried a regular Redis service before, and that one comes with a default configuration file, hence the reason why the Redis Cache plugin from Till Kruss works “out of the box”.

    So either you upgrade the redis service container with the redisearch mod OR you deploy Redisearch Docker image and use a default config from redis.

    After doing this change, the plugin succesfully can connect to Redisearch.
    Still working out some bugs with CSS and wp_search but the indexing is working properly with the container image.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘No option for password?’ is closed to new replies.