Support » Fixing WordPress » No-one Can Comment! Please Help!

  • Resolved Shari


    A couple of weeks ago, commenting to my blogs suddenly ceased to work. I will give the specs for the first blog only so as not to bog down anyone kind enough to help.

    Here are the specifics:

    1. WordPress blog url: Version 1.5.13

    2. Not exactly sure which version of PHP my host is using, but it is not the latest (4.1 or something earlier). Not sure which version of mySQL, but I could find that out if need be.

    3. Blog has been running for 2+ years with no problems whatsoever except for the odd hosting glitch.

    4. I do not allow users to register, so “anyone can comment”. However, since this problem began, no one can comment except me, and I can only comment if I’m logged in. Permalinks are default.

    5. When people try to comment, there is a long wait after clicking “Submit”, and eventually, IE (Version 7.0.5730.11) says, “Internet Explorer cannot display the page.” If I hit refresh, just a blank, white page loads, no messages. The page (or file) that is not loading is wp-comments-post.php.

    6. Attempted fixes: I have made sure the wp-comments-post.php file is not blank. I have backed it up, then replaced it with a copy from the install folder. No change. I have contacted my hosting provider (but not sure if it’s anything to do with them) and received no help. Not even a response, which surprises me. I have changed the theme back to the one I was using before, but commenting still didn’t work. I then changed the theme to WordPress default to eliminate themes as the possible source of the problem. I have gone into Admin -> Options and changed the WordPress URI and Blog URI by removing the “www” in the addresses. When that did not work, I changed them back to what they’d always been (www’s included). I have deactivated every single one of my plugins.

    6. Interesting, possibly helpful tidbit: all three of my blogs that are hosted with this provider are having the same problem, same results. One blog is hosted on this provider under a completely different account!

    7. Shortly after contacting my host, attempting to submit a comment on one blog, whether I was logged in or not, yielded a string of error messages which I could provide if needed. This was the case for about four hours, however, that is no longer happening. The problem is the same.

    8. Another common variable between all three blogs is that I was using the Spam Karma 2 plugin and did not upgrade to the new version when I got the message. I have since upgraded; no change. I deactivated and removed the plugin. Even the spammers can’t comment, and they can usually get around anything!!

    I have posted about this before (about two or three days ago) and got no hits. I wanted to update the thread with information about things I had tried, but couldn’t edit the original post, so this is the best way I can think of doing it. If anyone has suggestions about a better way to present problems, please let me know. I want to help you help me! 😉

    One last note, this problem sounds identical to the issue thomaspalley is having in this thread: .

Viewing 3 replies - 1 through 3 (of 3 total)
  • whooami




    I reallly have to say this, so please read this with the understanding that I honestly have the VERY best of intentions.

    You are worrying about commenting, and honestly, you shouldn’t be. You need to upgrade your blog, nothing else first — just that.

    2.0.10 would suit you fine as an upgrade and provide the security that you are currently lacking. It would also be the least painful upgrade.

    Please, please, upgrade your blog.

    Whooami, thank you very much for your reply, and yes, I do understand. I put off upgrading merely because I couldn’t find the time to sit down and do everything right. I had actually planned to upgrade very soon (waiting for word on whether Getz had any serious problems), when the comments problem hit.

    I made the assumption that I needed to fix the comments issue and then I could upgrade.

    Will I be able to fix this issue once I upgrade, do you think? And also, would I have to upgrade soon again if I didn’t go with the latest release?

    P.S. Will I be able to upgrade if I can’t log out of my admin panel? Currently, clicking “Logout” only redirects me to the Admin panel. Thanks again!

    Solved the logout problem by clearing temp files and cookies in my browser’s cache.

    And *crossing fingers* commenting seems to have been fixed by upgrading to 2.0.9!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘No-one Can Comment! Please Help!’ is closed to new replies.