Support » Plugin: WooCommerce Stripe Payment Gateway » No one can checkout, red exclamation point, no other message

  • Resolved curiouslt

    (@curiouslt)


    Since the last Woocommerce update no one can check out with Stripe. Once customer submits order, they get an error message of just a red circle with exclamation point.

    I did notice that when you try to make any changes in the Stripe payment settings, or even if you just click the “save changes” button, I get an error message:

    The “Test Publishable Key” should start with “pk_test”, enter the correct key.

    The “Test Secret Key” should start with “sk_test” or “rk_test”, enter the correct key.

    But Test mode is not enabled, it is in Live.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Don’t bother waiting for a response…. nobody answers anything around here, ever.

    Same problem too. I fixed the problem by going through an older version of the plugin.
    On the other hand, apple pay and google pay do not work in this version despite all the parameters being correctly configured.

    Plugin Support Saravanan S, a11n

    (@simplysaru)

    Hi @curiouslt

    Since the last Woocommerce update no one can check out with Stripe. Once customer submits order, they get an error message of just a red circle with exclamation point.

    Could you please enable logging and share with us the logs. Options to enable logs are under stripe settings. Detailed instructions on enabling the logs are here. Please also use the document to review your stripe setup as well just to ensure everything is setup correctly.

    Could you also share your System status report. You can find that by navigating to WooCommerce > Status > System Status. Then click on get status report to copy the information for us.

    While posting your logs here in the forums, please remove all sensitive information from the logs.

    I get an error message:

    The “Test Publishable Key” should start with “pk_test”, enter the correct key.

    The “Test Secret Key” should start with “sk_test” or “rk_test”, enter the correct key.

    Looks like your API keys for test mode is incorrect. Could you please delete the Test API keys and save the changes. Leaving that field blank will fix this error.

    Look forward to your reply at your earliest.

    fxeasy

    (@fxeasy)

    Save both live and test publishable key and secret key and webhook secret will solve your problem. 🙂

    Thread Starter curiouslt

    (@curiouslt)

    The test info will not save. I have tried multiple times from multiple browsers.

    Plugin Support AW a11n

    (@slash1andy)

    Automattic Happiness Engineer

    Hey again!

    It sounds like you had a live site with live payments, and now it’s set to use test mode.

    Test mode shouldn’t be active on a live site, and you shouldn’t need test keys at all.

    Make sure your Stripe plugin settings are set for live mode, and you have live keys saved in your settings.

    Thread Starter curiouslt

    (@curiouslt)

    No, i’m quite aware of test vs live. Someone suggested I needed to have the test credentials in, so I tried it. That wasnt what the issue was. I had to switch to a different Stripe plugin

    Plugin Support AW a11n

    (@slash1andy)

    Automattic Happiness Engineer

    Hey again!

    Sorry for the confusion there.

    Obviously we were hoping that this would be a quick one to sort out and you could keep using our plugin, but either way I am glad that you now have a working Stripe plugin on your site.

    Have a great one!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.