Support » Plugin: Contact Form 7 » No notification after clicking submit + constant processing icon

  • Resolved TNG1

    (@tng1)


    Hi All,

    I have a contact form set up for the submission of attachments. I am utilizing the “Drag and Drop Multiple File Upload – Contact Form 7” plugin on this form as well.

    Upon clicking submit, no confirmation/failure/whatever message is returned to the user but the subsequent emails the form is set up to send go out, and the submission is also captured via Contact Form CFDB7.

    The user just sees the submit button change color and the little ball rolling around in the larger ball icon, the form itself does not clear. From the user’s perspective it would be very reasonable to believe the form did not send…though it did.

    I’m running WordPress 6.0 on a headless Ubuntu 20.04 LTS server.

    Can anyone help me troubleshoot this?

    Cheers

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    Where can we see the website in question?

    Thread Starter TNG1

    (@tng1)

    Hello @takayukister, thank you for your reply.

    The form is here: https://pvunitedfc.com/registration-forms/

    • This reply was modified 2 months, 3 weeks ago by TNG1.
    Thread Starter TNG1

    (@tng1)

    @takayukister part of the issue might be associated with permissions dictated by the Ultimate Member plugin as the form is on a page with restricted access. I removed the restriction to share it with you here.

    The post-submit results changed slightly when I removed the restricted access. I still do not get a confirmation or failure message, but the form does clear and the spinning ball icon goes away.

    Thread Starter TNG1

    (@tng1)

    @takayukister for the purpose of making sure you have all the info needed to help me in this, here is the custom CSS applied to the form:

    /* registration form css */
    
    #wpcf7-f7828-p7810-o1 {
    	background-color: #ffffff;
    	padding: 10px;
    }
    
    .pv-form {
    	display: flex;
    	align: left;
    }
    
    #reg-2022-note {
    	max-height: 100px; !important
    }
    
    .pv-space {
    	padding-right: 10px;
    	margin-left: 25px;
    }
    
    .codedropz-upload-handler {
        border-radius: 25px;
    }
    
    /* end reg form submit form */
    Plugin Author Takayuki Miyoshi

    (@takayukister)

    What other plugins and theme do you use on the site?

    Thread Starter TNG1

    (@tng1)

    @takayukister the theme is FCUnited ThemeForest’s page for FCUnited

    Plugin list is long:
    Contact Form 7
    Cutom Twitter Feeds
    Document Embedder
    Drag and Drop Multiple File Upload – Contact Form 7
    Elementor
    Elementor Pro
    ELEX WooCommerce Name Your Price
    Events Shortcodes for The Events Calendar
    Events Widgets for Elementor and The Events Calendar
    Flamingo
    FluentSmTP
    Google Analytics for WordPress by MonsterInsights
    Loco Translate
    MC4WP: Mailchimp for WordPress
    SIP Advanced Email Notifications for WC Free
    Smash Balloon Instagram Feed
    Smush
    SportsPress
    SportsPress for Football (Soccer)
    The Events Calendar
    The Events Calendar Shortcode & Block
    ThemREX Addons, Socials, & Updater
    Ultimate Member
    Ultimate Member – Enable Profile Photo in Register Form
    UpdraftPlus – Backup/Restore
    User Role Editor
    WooCommerce
    WooCommerce Blocks
    wpForo
    Yoast SEO

    After discovering the issue I have also installed WP Adminify

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Please do not overuse the @<name> mentions.

    Forum Guidelines

    Do not abuse the @<name> mentions, they are not a tool to get faster responses.

    Plugin Author Takayuki Miyoshi

    (@takayukister)

    Try switching to the default theme and deactivating all plugins excluding Contact Form 7, Flamingo, and Yoast SEO.

    Why you are advised to deactivate plugins and switch to the default theme.

    Thread Starter TNG1

    (@tng1)

    So I followed your advice, switched to a default theme, and deactivated all plugins except for Contact Form 7, Flamingo, and Yoast SEO. The result was the form would not send at all.

    I played with various iterations of plugins activated and deactivated and different themes, different forms either containing the drag and drop or the standard file call…either it didn’t send at all, or it did with no notifications.

    Ultimately I deactivated and deleted Contact Form 7, Flamingo, and Drag and Drop Multiple File Upload – Contact Form 7. I then reinstalled all three and that did the trick. The form sends, refreshes, and serves up the success notice.

    I appreciate your replies and time on this issue.

    Cheers….

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.