• Resolved qsdnxu

    (@qsdnxu)


    Dear yoast team,

    Today I got that these of my pages has issue with indexing:

    It writes: Submitted URL marked ‘noindex’

    https://diydekoideen.com/

    https://diydekoideen.com/datenschutz-bestimmungen-und-cookied/

    https://diydekoideen.com/kontakt/

    When I turn off yoast plugin google can index it.
    and this line got removed: <meta name=”robots” content=”noindex, follow” />

    My robots txt:

    User-Agent: *
    Allow: /wp-content/uploads/
    Disallow: /wp-content/plugins/
    Disallow: /wp-admin/
    Disallow: /readme.html
    Disallow: /refer/
     
    Sitemap: https://diydekoideen.com/sitemap_index.xml
    Sitemap: http://diydekoideen.com/sitemap_index.xml

    Could you please give me a hand?

    Best,
    Thomas

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Maybellyne

    (@maybellyne)

    Hello Thomas,

    Thanks for reaching out about those URLs marked as noindex. On checking the page sources, all three URLs have noindex tags.

    You can set them to index by editing the respective pages. Next, scroll down to the advanced tab of the Yoast SEO metabox. Choose ‘Yes’ for the option to ‘Allow search engines to show this Post in search results?’

    Do let us know how it goes.

    Thread Starter qsdnxu

    (@qsdnxu)

    Hi @maybellyne,

    Thank you for helping me.
    Actually I can see what you are saying on the editor page of every post, although I can not find this yoast meta box in the editor of the pages. Do I miss something?

    Thanks for your answer,

    Thomas

    • This reply was modified 2 years, 5 months ago by qsdnxu.
    Plugin Support Maybellyne

    (@maybellyne)

    Thanks for the feedback, Thomas.

    Definitely, it sounds like the Yoast SEO meta box is missing for pages.

    – Can you confirm you have the right user permissions? You can check by going to Users > Your Name > Yoast SEO settings (may need to scroll down) and confirm that both “Disable SEO analysis” and “Disable readability analysis” are unchecked?
    – Can you confirm that SEO, Readability, and Insights are enabled by going to SEO > General > Features and checking that SEO, Readability, and Insights are enabled?
    – Can you confirm that SEO and Readability are enabled on the pages? You can check by going to SEO > Search Appearance > Content Types and seeing that the Yoast SEO Meta box says “Show”?
    – Can you confirm that if you go to the page and click on Screen Options (in the top right), are all the right options enabled? If you are using the new Gutenberg editor, you will need to click on the dots in the corner and select options. See image: https://pasteboard.co/I0PzCxd.png, which highlights how to check this.

    Do let us know how it goes.

    Thread Starter qsdnxu

    (@qsdnxu)

    Hi,

    I found the issue.
    The pages settings were off on this page: /wp-admin/admin.php?page=wpseo_titles#top#post-types
    Pages (page)
    Single Page settings
    Show Pages in search results?
    I turned this on.

    Thanks for your help!
    Thomas

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘No: ‘noindex’ detected in ‘robots’ meta tag’ is closed to new replies.