Support » Plugin: DsgnWrks Instagram Importer » 'No new Instagram shots to import' after first batch of imports

  • I have an Instagram account with 120 pictures which I’m trying to import into a new blog.

    I first tried importing all of them with no date filter, and it timed out after about 70, refusing to import any more with the ‘No new Instagram shots to import’ message.

    So I reset that WordPress install and this time tried importing from only the last few months as suggested to avoid time-out issues. This time it worked and imported the 41 posts in question.

    Now when I change the date filter back to previous months to gradually import my whole collection, I continue to get the ‘No new Instagram shots to import’ and no more are imported. So basically, it only seems to work for the initial run.

    I’ve tried deleting the user and re-authenticating. I’ve used the Debug plugin to wipe all users and options to start fresh. No luck so far.

    Any pointers would be welcome. I just need to have to import my entire collection of images, even if it requires multiple passes. How do I force the plugin to consider the older Instagram posts it seems to ignore after its first run?

    Thanks in advance.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Justin Sternberg


    Sorry for the frustration. Do me a favor and import all the photos it will allow. After it’s done, right-click on the ‘import’ button, and tell it to open in a new tab/window. This should have the import run manually a different way. Let me know if that imports any other photos.

    Justin, thank you for the prompt response.

    I’m quite fine with some minor frustration, considering your plugin does exactly what I need. Thank you for putting the time into developing and supporting this. Much appreciated.

    As an immediate experiment, I tried out the “Import+Open in new window” method you describe on my existing install, with the 41 existing posts. Tried this with various combinations of date filter being on and off, and also auto-import being on and off, which I found made a difference on a prior run a few days ago. Unfortunately it still came up with

    No new Instagram shots to import

    every time.

    This is a new site, so I have the luxury of starting fresh. Will do a reset on this install of WordPress later today and see if I can get different results. Will report back.

    Thanks again for the help.

    Plugin Author Justin Sternberg


    Hmm, not cool. yah, do a fresh import ONLY using the import-right-click method after deleting all the posts and let me know. The posts cannot be in the trash, or they’ll still register as imported.

    Hmm, still no luck. All importing was done only using the right click method. Please bear with the detailed commentary. I’m just hoping it helps. Here’s everything I tried.

    First deleted all posts, cleared trash and tried importing with date filter off. It imported only the last two Instagram posts.

    Cleared posts again and used your debug plugin to clear user and options. Imported. Last two posts again.

    Noticed that while the post body settings had been lost, the other options seemed to be remembered even after the debug-plugin based reset, so went into the database and deleted all Dsgnwrks options under wp_options. Cleared posts and tried again. Same result.

    Now dropped all tables in the database, deleted all files in /wp-contents/uploads/ … installed WordPress again. Setup options. Imported. Same result. Just 2 posts, and nothing after.

    Now it’s not even getting back the 41 or 70 I managed before, so could it be some sort of API throttling that’s getting applied? Perhaps my server triggers something?

    One thing I did notice is that the URL in the dsgnwrks_next_url option in the database includes a “&count=2”, which is the number of posts it’s getting, though unfortunately not even 2 new ones every time. Still shows the “No new Instagram shots to import” message as soon as there’s the 2 imported posts in WordPress.

    Any thoughts are welcome, and thanks for the help.

    And this is my account, if that helps narrow some factors down:

    Any updates on this issue. I just downloaded this plugin and I am having the same issue. I’ve attempted the same procedure listed above, but no dice.

    I’m having the same issue. I tried the right-click Open in a new window after deleting (and emptying trash) of the two images it managed to import on my test run. It imported those and that’s it.

    I used the code posted here and it fixed the issue for me –

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘'No new Instagram shots to import' after first batch of imports’ is closed to new replies.