WordPress.org

Forums

Google XML Sitemaps
[resolved] No new articles / posts are listed in the sitemap.xml (10 posts)

  1. robbee82
    Member
    Posted 1 year ago #

    Hello,
    i still have to use the 3.4 version because new newest one is not working due to unknown reasons.
    Since a few months i actually got the problem in version 3.4, that no new single blog articles got added to the sitemap.xml. Only the startpage is getting updated when i publish a new post. When i update single articles that already are listed in the sitemap, they get an updated entry in the xml.
    I do not really know, what issue initated this error.
    Does somebody had this problem in earlier versions of the Plugin?

    Kind regards

    https://wordpress.org/plugins/google-sitemap-generator/

  2. robbee82
    Member
    Posted 1 year ago #

    By the way, the problem i've got with the newest version 4.0.3 is, that files like "sitemap-pt-post-2014-03.xml" are empty, without any blogposts published in this period.
    Maybe somebody can instead help me out with this issue...

  3. cl170319
    Member
    Posted 1 year ago #

    Здравствуйте! У меня не работает карта сайта. не могу понять мои действия, чтобы создать карту. http://nina-kovalencko.com

  4. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    can you try the dev version? I've fixed a small bug regarding the dates and GMT/local time zone handling. Thanks!

    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

  5. robbee82
    Member
    Posted 1 year ago #

    Hi Arnee,

    thanks for you reply. Unfortunately the newer posts still are not added to the particular sitemap, like "sitemap-pt-post-2014-03.xml". The "last modified" date is updated, but it's still empty.
    I can't remember exactly, but before using your plugin our sitemap was managed through "WordPress SEO by Yoast". I think we switched to your plugin in September 2013. Since then (i guess), most of the new posts are not added to the sitemap and the problem seems to exist even with version 4.0.4. :(
    Is there a setting our server does not support or are there any problems known running the Yoast-Plugin parallel (of course i've deactivated the XML-Sitemap function there)?

    Kind regards

  6. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi robbee,

    There was one more little bug, can you give the new dev version (4.0.5) a try?

    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

    If it still exists, we might have to check in detail if there is something wrong with the content of your posts table.

  7. robbee82
    Member
    Posted 1 year ago #

    Hi Arnee,

    I really appreciate your help! Thank you. I've just tested the 4.0.5beta1 in a staging environment. A new realeased article appeared in the "sitemap-pt-post-2014-04.xml", wonderful! So this seems to work. :)

    The problem that still exists is, that posts which are already published, are not added into the sitemap.xml or any sub-sitemap. Even if i release them again with the same or the actual date they are not appearing in the sitemap although the sitemaps are getting an updated "Last modified" date. So the remaining question is, how to get these posts into the new sitemap?
    Would be great, if we can find a solution for this problem.

    Kind regards

  8. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    are you using a caching plugin? Please also try the test version, which improved the compatibility with some of this plugins:

    http://downloads.wordpress.org/plugin/google-sitemap-generator.zip

    Thanks!

  9. robbee82
    Member
    Posted 1 year ago #

    Arnee, you are the best!
    I've just tested the 4.0.5beta2 and it worked fine! All missing posts are now listed in the sub-sitemaps, no matter if the cache plugins are activated or not. By the way i'm using Cachify und Quick Cache.
    I'm really happy you could help me out with this problem, fantastic job!!! Should i wait for the final 4.0.5 release or can i install this beta also on our live environment already?

    Kind regards

  10. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    You can use the beta safely, I will probably release it exaclty like this in a few days.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google XML Sitemaps
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic