WordPress.org

Forums

[resolved] No network setup in tools after adding multisite code to wp-config.php (6 posts)

  1. Timjim
    Member
    Posted 1 year ago #

    I've read that 99% of the time it is a user error that causes this to happen and have tried reading through the forums, but I still can't get my 'network setup' option in my 'tools' menu.

    I followed the guidelines at:
    http://codex.wordpress.org/Create_A_Network
    Turned off all plug-ins and checked permalinks (set to post name)

    Below are a selection of further user's solutions which I've tried:

    Editing text in wp-config.php in a plain text editor (ubuntu text editor and Blue Fish) then uploading by FTP

    Editing text in wp-config.php by hand (not copy and paste) then uploading by FTP

    Using define('MULTISITE', true); instead of define( 'WP_ALLOW_MULTISITE', true );

    If I try going to mysite.com/wp-admin/network I get 'You do not have sufficient permission to access this page' even though I've been giving main administrator's login details (I can delete all other users)

    Perhaps the location of the WP install is an issue as it is located at /root/.aptitude/g/mysite.com/ ?????

    The WP install was done by someone else on a VPS server, for which I am still yet to get hold of login details for admin panel.

    Below is the later part of my present wp-config.php

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    ?>

    Is this still user error or is it time to contact the host?

    Thanks anyone if you can offer help

    Tim

  2. I think maybe you should try refreshing your page or logging out and back in and then check Tools menu after you have put this

    define( 'WP_ALLOW_MULTISITE', true );

    Into your wp-config. And I have no trouble suggesting to cut and paste. It's very easy to mistype something.

  3. Timjim
    Member
    Posted 1 year ago #

    Thanks for your reply The WP Valet.

    I tried cutting and pasting again from the text in your reply. Interestingly, in my email your text appeared as below:
    define( 'WP_ALLOW_MULTISITE', true );

    So I tried that also, but still no Network Setup option in tools menu

    End of my wp-config.php looks like this:

    define('WPLANG', '');
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    ?>

    Any alternative ideas?

    Thanks

  4. You didn't actually do what he suggested :)

    Read http://codex.wordpress.org/Create_A_Network#Step_2:_Allow_Multisite

    See how it says you have to refresh? Then go on to step three. There's a whole nother chunk you have to copy in, and you're missing it.

  5. Timjim
    Member
    Posted 1 year ago #

    Solved.

    I'd inherited this WP install from two previous developers and it was located on a VPS server without admin management. That's why I was uploading by FTP.

    What I hadn't been told was there were other installs of WP on the server and I had been given directions leading me to the wrong one.

    So, looks like adding the line
    /* Multisite */
    define( 'WP_ALLOW_MULTISITE', true );
    Does always work, just make sure you are working on the correct install!

  6. 1503wmike
    Member
    Posted 1 year ago #

    I've done all of the above, checked and checked again. Network setup tells me there is an existing network. So, how do i access it?

    Using latest version of WP - 3.8.1

    Stuck.

    Any suggestions, anyone, please?

    Cheers,

    Mike

Topic Closed

This topic has been closed to new replies.

About this Topic