Support » Plugin: WPaudio MP3 Player » No MP3 Play Button, Just a Link!

  • I have <?php wp_footer(); ?> and <?php wp_header(); ?> in my documents, I have tried all three variants (a href, wpaudio url, audio), but it displays the name of the MP3 file as a clickable link. No play button.

    This plugin actually used to work briefly when I was building the site on an IP address. Once I switched over to the actual URL of the site, the plugin no longer works. The URL of the mp3 files does match the URL in WOrdPress blog settings, so that’s not the issue.

    I’ve also deleted the plugin and reinstalled it. Nothing works. Any ideas?

    Any suggestions for another plugin similar to this one that offers a download button? This plugin is perfect, but if it won’t work I need another solution asap.

Viewing 10 replies - 31 through 40 (of 40 total)
  • That is interesting… I think it’s getting to the point where this plugin should probably be re-written by someone in the developer community… I wonder if anyone could take that on?

    This is where I wish I was a full developer – but I’m still learning… 😉

    Thanks for posting your solution – I hope it helps some of those who are still having issues with this plugin!

    I’m glad I came across this post and it saved me! Ursula solution didn’t work for me out of the box. I noticed my site wasn’t using the “min” version of the javascript file, so I had to make this same change in the wpaudio.js file.

    Change line 425 from:

    jQuery('a[href$=.mp3]').addClass('wpaudio');

    to

    jQuery('a[href$=".mp3"]').addClass('wpaudio');

    Again, the fix is the same as Ursula’s (thank you thank you thank you for that by the way) it just had to be applied to a different file. Hopefully this will help someone else.

    Hello,
    I have tried the fix: Search for

    href$=.mp3 and replace by href$=”.mp3″

    and now it works fine with the Browsers: Firefox and Opera,
    and also Chrome and Safary. (It is important to empty the cache before trying the plugin).
    Thanks!

    After making all of the tweaks, I have found that WPaudio plugin clashes with the Mime Type Link Images 2.0.4 plugin.

    Just so you know: I had to make the change in both js files (wpaudio.js and wpaudio.min.js), and then it worked. Weird.

    steadwell: plugins don’t all play nice with each other, so it’s good to know what conflicts with WPaudio. Thanks for sharing!

    Thank you for the update, flomincucci. This may be very helpful information for others as well – appreciate you sharing!

    I am having a weird issue with Firefox 8. (At least I think it is 8, I can’t keep up with the rapid release schedule. For all I know I just updated to FF 22).

    Anyway, I digress. I am trying to use WPaudio with the WP-Tables Reloaded plug-in to create a sortable and searchable table of mp3 files. In the last column, there is the WPaudio play button along with a download button so people can save it if they want. This works great in Safari, Chrome, and IE (yes, even IE works except IE7 but that’s another story).

    Firefox, however does not want to play nicely. If I have the table to display the first 10 rows on page load, it looks great. Both buttons are in place. But, if you go to page to or change it to display more than 10 after page load the WPaudio play button does not appear. The link is there but it just has the title with no class=”wpaudio” and an a href=”#” link associated with it.

    In an unrelated but similar situation, I was trying to upload a custom icon to a saved Google Map and Firefox would not display the image I used. I tried doing it in Safari and it worked just fine.

    So, now in two different instances, Firefox had an issue with desplay an image.

    Has anyone heard about what is causing the latest release of Firefox to act this way?

    I tried Ursula’s suggestion and nothing so there doesn’t seem to be anything wrong with WPaudio since every browser works in other than Firefox.

    I am still having a problem.

    I think it is because my wpaudio.min.js and wpaudio.js files are inactive

    is there a way I am supposed to “activate” them?

    the .php file is active.

    i just registered to thank URSULA for her advice on getting the wpaudio plugin to work. the quotation marks did the trick. so: thank you, ursula 😉

    PS: i like THIS plugin so much becuase it is small, clean and actually STOPS playing a file when you start another, which is nice on a start page or if you have multiple players on one site.

    @ursula, Thanks! Added quotes around .mp3 and all is well. So appreciate being able to still use this plugin. 😉

Viewing 10 replies - 31 through 40 (of 40 total)
  • The topic ‘No MP3 Play Button, Just a Link!’ is closed to new replies.