Support » Plugin: WPaudio MP3 Player » No MP3 Play Button, Just a Link!

  • I have <?php wp_footer(); ?> and <?php wp_header(); ?> in my documents, I have tried all three variants (a href, wpaudio url, audio), but it displays the name of the MP3 file as a clickable link. No play button.

    This plugin actually used to work briefly when I was building the site on an IP address. Once I switched over to the actual URL of the site, the plugin no longer works. The URL of the mp3 files does match the URL in WOrdPress blog settings, so that’s not the issue.

    I’ve also deleted the plugin and reinstalled it. Nothing works. Any ideas?

    Any suggestions for another plugin similar to this one that offers a download button? This plugin is perfect, but if it won’t work I need another solution asap.

Viewing 15 replies - 16 through 30 (of 40 total)
  • Thanks Ursula! You rock!

    ok, spent a night debugging the javascript – theres some pretty cool stuff in there (including abit i havent seen before (prototyping) ) but i never got the bottom of why this never worked in IE8 correctly.

    i ended up building my own simple audio player plugin based on jplayer… i may release this at some point, if there is any interest.

    I’ve tested my site with my fix in IE9 and IE8 and they both work for me – not sure why it wouldn’t work for you, cybacolt – did you try my solution?

    Here’s the page in which I use it:

    Tathiana.com/music

    @cybacolt,

    i ended up building my own simple audio player plugin based on jplayer… i may release this at some point, if there is any interest.

    I’d definitely be interested.

    Tried the “.mp3” fix but it’s still not working in IE for me. I get the message:

    Message: Object doesn’t support this property or method
    Line: 22
    Char: 162
    Code: 0
    URI: http://fourwallflight.com/music/you-pursue-me/

    Any other ideas? Would really like to keep this plugin but it’s dead in the water right now for us.

    Thanks, Ursula, you’re my hero. I’d replaced WPAudio with another player and wasn’t as happy with it. I implemented your fix and it worked like a charm. I’ve tested in IE8.x and latest Firefox, Chrome versions and it works again. THANK YOU!

    drummergirl – just checked your site, and it looks like you found another player to work with. I checked it out – it seems really nice, actually! Glad you found something that works well!

    tomgray – You’re quite welcome! I know the feeling – in my case, I really didn’t want a flash player so I found this one and didn’t want to lose it either. I figured I wasn’t the only one in the same boat after finding the forum, so I posted the solution that worked for me. 🙂

    Another one that looks good that drummergirl is using is the following, in case anyone else wants to try it:

    http://wordpress.org/extend/plugins/haiku-minimalist-audio-player/

    “A simple HTML5-based audio player that inserts a text link or graphical player for audio playback. Compatible with WP Audio Player style links, fully accessible and degrades gracefully, and includes Google Analytics tracking of audio plays. Based on jPlayer.”

    This one looks so nice I’m considering swapping to it, especially since it’s HTML5-based, and it’s been updated more recently (and compatible with 3.2.1).

    Hope that helps, guys!

    Thanks WP Gal – totally worked for me after I updated to the latest version of WP!

    Great to know – glad it worked! 🙂

    did the quotation mark thing. didn’t work.

    Home

    we post a lot of audio files. please help!

    Thanks, this saved my blog! Not only were the audio links not generating the player, the error prevented the jQuery widget in my blog header from loading.

    http://cogdogblog.com/2011/08/15/diy-is-fixing-your-blog/

    I may have never found the reason w/o checking here.

    Now how can the plugin be updated if the developer is AWOL.

    @wp Gal

    I had to reinstall my blog and start over. I edited the file you said to edit, made the change but it’s not working. It opens the link in a new tab and plays the mp3. I don’t understand because I did what you suggested before and it worked. There is only one entry for the href mp3 in that file correct?

    Thanks,

    Jaco

    Hi Jaco!

    As far as I know, yes, it’s just the one line, but maybe there’s another plugin causing a conflict? Have you tried disabling all other plugins and just leaving this one?

    Unfortunately, I’m not the developer for this plugin (nor am I a full-out developer yet – I just know how to tweak code), so the only other suggestion I have would be to try a different player, like this one:

    http://wordpress.org/extend/plugins/haiku-minimalist-audio-player/

    Wish I could help more! I know there have been a few of you who still have the issue, but most have had the issue resolved with the code tweak, so I’m not sure why it’s working for some but not others. 🙁

    I’m with Jaco23. My site was working as it should, then either the latest WP update broke something because now the .mp3 links also open in a new window. I edited the .js file ( nice catch Ursula) but that didn’t fix anything, same issue. I deactived all the plugins, no change.

    The odd thing is that another plugin is also not working as it should, the Lightbox Plus one. These both are on the same page: http://www.madrigaldinner.com/samples/
    and they both stopped working at the same time, but different functionality, hmmmm.

    I am stumped and hoped sooo much that Ursula had found my fix, but sadly no.

    Anyone else found another fix maybe?

    Cheers,

    c

    Ok, after some debugging in Chrome on a Mac, I tried this and now it works again…

    Ursula was close for me, but her fix didn’t do it. Then another post said to remove the . infront of the mp3, so I tried BOTH of those and now I am back in business.

    Tested in Safari and Chrome on a Mac, and I will do some more now that I have it working. So, here is my fix….

    wpaudio-mp3-player/wpaudio.min.js This is the file I edited

    NOT WORKING CODE: {jQuery(‘a[href$=.mp3]’).addClass(‘wpaudio’);}

    WORKING CODE: {jQuery(‘a[href$=mp3]’).addClass(‘wpaudio’);}

    I too am not a coder, just an old web designer ha ha ha, but I have worked with enough pages of code to feel comfortable rummaging around in there… so, it now works for me, but the adding of the ” ” marks didn’t… go figure.

    I hope it helps some of the rest of you that were not having any luck either.

    Cheers,

    Cory

Viewing 15 replies - 16 through 30 (of 40 total)
  • The topic ‘No MP3 Play Button, Just a Link!’ is closed to new replies.