WordPress.org

Support

Support » Plugins and Hacks » WPaudio MP3 Player » No MP3 Play Button, Just a Link!

No MP3 Play Button, Just a Link!

  • I have <?php wp_footer(); ?> and <?php wp_header(); ?> in my documents, I have tried all three variants (a href, wpaudio url, audio), but it displays the name of the MP3 file as a clickable link. No play button.

    This plugin actually used to work briefly when I was building the site on an IP address. Once I switched over to the actual URL of the site, the plugin no longer works. The URL of the mp3 files does match the URL in WOrdPress blog settings, so that’s not the issue.

    I’ve also deleted the plugin and reinstalled it. Nothing works. Any ideas?

    Any suggestions for another plugin similar to this one that offers a download button? This plugin is perfect, but if it won’t work I need another solution asap.

Viewing 15 replies - 1 through 15 (of 40 total)
  • i’ve worked out the fix for this. (i’d fork it on git, but there’s no repo for it?)

    this is an easy fix, but it requires you to feel comfortable to edit some code:

    open the javascript file here:
    /wp-content/plugins/wpaudio-mp3-player/wpaudio.min.js

    search for:
    href$

    directly after it you should replace:
    .mp3
    with:
    mp3

    (remove the dot…)

    save it, reload your blog and it should all be good. (you may need to purge your cache if your using IE)

    cheers to Todd for a great plugin!

    @cybacolt Thanks for this. I’ve deleted the . in .mp3 and uploaded the changed file but I still have the same problem. Just a link and no player. Very frustrating! This is the BEST plugin….if I could just get it working!

    @ cybacolt me too i’ve done all u said yet its not working for me.

    hrrm. the error i fixed related to a javascript error. my links started working automatically as soon as i fixed it. i’m using WP 3.1.1…

    at this point all i can suggest is to look at your html source and make sure:
    1) jquery is being loaded (should be at the top, in the ‘head’ somewhere)
    2) wpaudio.min.js is being loaded (should be at the bottom, just above the ‘body’ tag)

    i’m afraid theres not much else i can do without looking at your setups directly, sorry!

    Ok this is my domain.. mp3ghana*com replace * with . check it works in chrome but not firefox and firefox is the major browser in my country.

    I removed the . (dot) per your instructions and the audio player still did not work.

    After some plugin deactivation’s, I found that the FancyBox for WordPress plugin (version 2.7.5) was causing the WPAudio player not to load on posts/pages.

    It works now on WP 3.1.2.

    so theres various problems here…

    while its working in firefox/chrome, i’m still getting javascript errors in IE8…

    at this point i’ll probably have to work on a different solution… pity!

    Looks like the plugin needs some TLC and an update.

    I believe I’ve found the solution – click here to read what I tried – seems to have resolved the issue for me:

    http://wordpress.org/support/topic/js-quotation-marks-error?replies=2#post-2201545

    Just so the answer is here as well, I followed these steps:

    open the javascript file here:
    /wp-content/plugins/wpaudio-mp3-player/wpaudio.min.js

    Search for href$=.mp3 and replace by href$=”.mp3″

    (ie. add the quotation marks before/after .mp3)

    Worked like a charm Ursula! Saved me a lot of heartache.

    Thanks

    You’re welcome! No worries at all – I was facing the same issue, and when I saw that I wasn’t alone, I had to post the solution. 😉

    I can not for the life of me find that line in the wpaudio.min.js file. (Update) I found the entry ……works like a charm. Thank you so much!!!

    Jaco

    Make sure the plugin itself has been updated to the latest version as well.

    Use the CTRL+F function and just search for HREF – perhaps with and without the symbol – otherwise, try searching for =.mp3 and see if you can find it that way. It was definitley there for me and at least one other person! 🙂

    Worked for me too – thanks!

    No problem! 🙂

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘No MP3 Play Button, Just a Link!’ is closed to new replies.
Skip to toolbar