WordPress.org

Forums

No more comment counting (26 posts)

  1. Mazalien
    Member
    Posted 9 years ago #

    After upgrading from wp 1.5.2 to wp-2.0 the new version has
    stopped counting my comments below the posts.It only shows the
    old amount of comments and not the new ones that were added
    after upgrading.

    For example if there where 4 comments before upgrade
    below the post the tag comments_popup_link said ;
    4 comments.
    After upgrade it still says that there are four comments
    even there where new ones added.

    Anybody knows a solution?

  2. Mazalien
    Member
    Posted 9 years ago #

    Macmanx

    Thanks. I have uploaded the new file and made a test comment.
    Nothing changeed.
    This does not work for me.
    Even in the adminarea (manage-post-area) only the old
    amount of comments shows up next to the post. But in the comment
    edit area the comments are really there...

    What to do now?

  3. In this case, I recommend that you re-open ticket #2159 and add a comment to it.

    http://trac.wordpress.org/ticket/2159

  4. Mazalien
    Member
    Posted 9 years ago #

    macmanx I reopend it. now lets see whats going to happen.

  5. vide
    Member
    Posted 9 years ago #

    I need to change 100 posts like such way? Huh..

  6. cdorr
    Member
    Posted 9 years ago #

    I just upgraded as well and I'm having this same issue. I did notice in the support tickets that they said something about spam karma effecting it. I have deactivated Spam Karma and it's still not working.

    is this being addressed by the wordpress crew or has it been fixed and I need to patch the code some how?

    Thanks,

  7. tinarenee
    Member
    Posted 9 years ago #

    same here. I've deactivated all plugins and reactivated one at a time and there is no difference in the comment counts. All the new comments I've gotten - on new posts or old posts - aren't counted.

  8. joshteeters
    Member
    Posted 9 years ago #

    I just wanted to add that I'm having a similar problem. No matter how many comments a post has, on the main index, it shows '0 Comments'. On the post page, it shows 'No Comments', right above.. 3 or 4 comments.

    I read that SK caused this. I downloaded the 2.1 beta of SK, as well as the SK+WP2Compatibility plugin. I installed both, following the directions.

    Guess what? Still '0 Comments'.

    I also tried disabling SK completely, and it still shows '0 Comments'.

  9. tinarenee
    Member
    Posted 9 years ago #

    Update:

    not satisfied with throwing in the towel so easily, I tried the upgrading to SK2 beta and uploading the sk2 compatibility plugin - even tho I didn't think it was an SK2 problem... Now, all new comments (since this SK2 beta) are being counted, BUT - I had to go in and edit all the comments created between my WP2 upgrade and this SK2 upgrade so that they would show in the comments. *shrug*

  10. shiner25
    Member
    Posted 9 years ago #

    well you know the solution.. stay with 1.5 in till they can produce a working upgrade.. pretty simple solution..

  11. joshteeters
    Member
    Posted 9 years ago #

    I found a solution that gets all of the comment counts back to the right number.

    Install SK2.1b as well as the compatibility plugin. Go to Options -> SpamKarma -> Approved Comments. Select 'em all, and run them through the WPCompat plugin.

    Fixed the problem on my end.

  12. callistawolf
    Member
    Posted 9 years ago #

    That worked great for me, joshteeters, thank you!

  13. anant_27
    Member
    Posted 9 years ago #

    Where can I find the WP compatibility plugin ? I am having the same problem with comment entries.

    Thanks
    Anantha

  14. tinarenee
    Member
    Posted 9 years ago #

    well dang, joshteeters - that is what I shoulda done. Don't I feel like a moron?? lol. Thanks for the heads up.

    anant_27 - go to: http://paulaoffutt.com/blog/archives/2005/12/28/wordpress-20-upgrade-process/

  15. joshteeters
    Member
    Posted 9 years ago #

    Sure thing everyone, glad it helped.

  16. gfmorris
    Member
    Posted 9 years ago #

    Thanks for all the pointers, folks. :D

  17. donjz
    Member
    Posted 9 years ago #

    Thank you!

  18. drabiej
    Member
    Posted 9 years ago #

    Quick question... how can I select _all_ my comments in SK instead of just he most recent 30?

  19. thane
    Member
    Posted 9 years ago #

    to drabiej:

    my solution, not sure, not responsible ;)
    just work for me..

    1. open "spam_karma_2_plugin.php" in SK2 package
    2. go to "518" line, where u see this: $query_limit = 30;
    3. replace with this: $query_limit = 5000;
    4. save & upload

    good luck :)

  20. drdave
    Member
    Posted 9 years ago #

    Just to put the final word on this:

    - WP 2.0 is *not* compatible with SK 2.0. In order for the two of them to play nice, you need to install SK 2.1 (now final), available on the main site at: http://unknowngenius.com/blog/wordpress/spam-karma/

    - You do not need the compatibility plugin with SK 2.1 (it was only used to make SK 2.0 compatible).

    - If you had previously miscalculated comment counts on certain posts, follow the instructions above to have SK2.1 re-parse these comments and update the comment count.

    Contact me if you bump into any problem...

  21. MichaelH
    Member
    Posted 9 years ago #

    "- If you had previously miscalculated comment counts on certain posts, follow the instructions above to have SK2.1 re-parse these comments and update the comment count."

    I'm not an SK2 user, but just for clarity, which instructions above should be used to re-parse and update the comment count?

  22. edsfchan
    Member
    Posted 9 years ago #

    Hi, I got lead here through this post: http://wordpress.org/support/topic/54574.

    I'm having problems with the comments displaying properly. Worse it's not displaying any of the older comments. I've tried installing SK2 and following the instructions here but it hasn't worked.

    Have a look at http://www.swordfishdragonboat.ca. Any help would be appreciated. Thanks.

  23. Tilex
    Member
    Posted 9 years ago #

    Thanks your the pointers guys! I had the same problem since I upgraded to WP 2 a couple of weeks ago. I deactivated Spam Karma 2 and installed the new version (i think it's 2.2). Now everything's back to normal! Yay!

  24. OrchidRed
    Member
    Posted 8 years ago #

    I second MichaelH's comment - which instructions?

    Thanks to everyone for their time and patience.

  25. whoneedsoxygen
    Member
    Posted 8 years ago #

    I know this was posted a while ago, but I too am experiencing the comment problem. My comment counts won't update to the proper count. I have installed the new SK, but there was no change to the comment problem.

    I'm not sure how to go about the re-parsing of comments, though.

    Just wondering if anyone else still has this issue, or any pointers?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags