Support » Plugin: The SEO Framework » No meta description in SERP

  • Hi there,

    I’ve never manually provided title tags or meta descriptions for at least a year now, because Google has gotten smart enough to pull the H1 tag as the title tag if you don’t provide it.

    What’s more, Google generates a dynamic meta desciption from your content based on the search query if you don’t “dictate” to google the meta description (i.e. if you don’t provide any).

    This has been working great for months, as I said.

    I used to use YOAST SEO for that, without issues.

    However, ever since I switched to your plugin, Google is no longer showing any meta descriptions in the SERP, which has caused a huge loss in rankings and traffic.

    Obviously, I’m still not providing any meta description, but somehow your plugin seems to prevent google from creating their own meta.
    My guess is you actively tell them the meta is “empty string” or whatever.

    Can you please tell me if there’s a fix for that, or do I need to switch away from your plugin?

    Thanks so much!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sybre Waaijer

    (@cybr)

    Hello!

    Are you located in France? Google was forced by France’s government to ask for your approval to take content, so they abide by a new copyright directive. If you do not opt for consent, Google isn’t allowed to show any textual “preview” content from your site, including descriptions.

    But, if you’re not located in France, then you might’ve accidentally opted out from showing description snippets altogether.

    At “Robots Meta Settings > General > Copyright Directive Settings”, you can find the options for this. Those options alter the robots-metatag value attribute.

    Make sure that “Maximum text snippet length” isn’t set to “None, disallow snippet”. Preferably, it should be over “320 characters”, or even set to “Unlimited”.

    If this wasn’t set incorrectly, then I’m afraid I need to take a closer look at the site affected. Perhaps Google delays the processing of the pages because it requires JavaScript to render fully?

    Hi Sybre,

    thank you for your quick answer.

    1) No, I’m not located in France, so we can exclude that at a reason.

    2) The settings at “Robots Meta Settings > General > Copyright Directive Settings” were set to “unlimited”.
    I had found this suggestion of yours as an answer to a different question, so I thought “this might be the solution!”.
    But alas, it was already set to unlimited.

    3) Thank you for offering to take a closer look at the site.

    For now, I’ve just switched back to YOAST SEO, simply to see if that makes a difference and brings back the meta descriptions.

    If it does, then we know it’s definitely to do with how your plugin works, and then we can look for a possible solution, how does that sound?

    I’m not sure, though, how long it will take for google to update their index (already re-submitted the main pages in search console).

    Thank you!

    Plugin Author Sybre Waaijer

    (@cybr)

    Alright 🙂 Keep me posted!

    It can take anywhere from a few seconds (I’ve seen this happen!) to a few days for Google to reparse your content.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.