Support » Fixing WordPress » No menu drag and drop in 3.4.1

  • I am using now using 3.4.1 and suddenly I can’t drag and drop in my menu.I can’t move my pages around at all. I can only add a new page to the end of my list as a main page, not adjust it to a “child” page. Anyone else having this problem? Solution needed!

Viewing 15 replies - 1 through 15 (of 22 total)
  • Check and see if there is a JavaScript error. What browser are you using?

    I’m using firefox but I opened my dashboard in google chrome and safari with no luck. I tried to open it in internet explorer but it immediately crashes. I’m not really sure how to see if there is a javascript error, what do I do? I also already tried deactivating all my plugins but that didn’t work. Thanks

    esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    I tried the theme fix and that didn’t work but I’ll try the other solutions. Thanks for taking the time.

    I am having the same issue…

    running on a freshly installed linux box, all files uploaded, correct chmod’s, all server dependancies (apache,php5,mysql,curl) and any drag and drop functionality does not work.

    I have already tried:
    – Using a diffrent browser (firefox, chrome, ie, opera, safari)
    – clearing cache
    – Tries re-uploading wp-admin & wp-includes
    – No Plugins installed…

    still nothing is working.

    I’m getting the following error in Chrome:

    Uncaught ReferenceError: postboxes is not defined load-scripts.php:29
    wpNavMenu.initToggles load-scripts.php:29
    wpNavMenu.init load-scripts.php:29
    (anonymous function) load-scripts.php:29
    f.Callbacks.o load-scripts.php:2
    f.Callbacks.p.fireWith load-scripts.php:2
    e.extend.ready load-scripts.php:2
    c.addEventListener.B load-scripts.php:2

    I’m using FF and Safari, can’t drag and drop anything, even have issues with features on some plugins that I have to dirty fix, or whatever it’s called when you skirt the regular feature and try something else. Right now I’m linking new posts to existing widgets. I’ve tried resetting the plugins, but still nothing budges. Website is purefilmcreative.com. If it’s not plugins, is it a theme problem? Is it a WordPress 3.4.1 problem? I have no clue about code or much else, so I hope the fix is basic.

    Thanks in advance for any help.

    Another one here. Is it possible to roll back wordpress?

    My issue turned out to be a conflicting plugin. Try disabling plugins one at a time to determine if one of your installed plugins is the offender. It may be a plugin that isn’t even active so don’t skip over inactive ones.

    Thanks Stephen
    I did the same and all seamed normal again.
    Jeremy

    same as @xymantec here.

    besides not being able to drag, I also cannot add categories to posts, when I click on add categories nothing happens, just as in:

    http://wordpress.org/support/topic/help-my-widgets-add-tags-to-posts-button-arent-working?replies=3#post-3132017

    do you replicate those other problems too?

    With firebug on firefox, I see get two javascript errors:

    * http://cirosan.web44.net/wp-admin/load-scripts.php?c=0&load=jquery,utils&ver=3.4.1

    …ct it.</b></font></td></tr></table>
    /*! jQuery v1.7.2 jquery.com | jquery.o…

    * http://cirosan.web44.net/wp-admin/load-scripts.php?c=0&load=admin-bar,hoverIntent,common,jquery-color&ver=3.4.1

    …ct it.</b></font></td></tr></table>
    if(typeof(jQuery)!=”undefined”){if(type…

    For those that asked, to see script errors on Firefox, install Firebug addon, open it with F12, then go console > errors and reload the page.

    I have the “drag and drop of menu pages not working” issue with WordPress 3.4.2 and it seems to be nothing at all top do with plugins. So, I experimented:

    1. I installed a brand new, vanilla 3.3 WordPress – NO additional plugins
    2. I defined three pages
    3. I defined a Primary navigation menu
    4. I could drag and drop the pages to re-order the menu
    5. I did the automatic update to 3.4.2
    6. Now drag and drop does NOT work on the menu – just highlights text

    So, I’d say there is something wrong with 3.4.2 and it’s nothing related to plugins.

    Very annoying! Fortunately, I kept several old versions of WordPress.

    I completely forgot about this issue which I was able to resolve a while ago but since I got an email with someone else experiencing the problem I will elaborate on the problem and solution…

    The Problem:
    The problem is being caused by certain wp files that require chmod access of 664 or local read and write access aka group access. Some folders require chmod access of 775 for the same reason, this all depends on your box’s configuration and how you went about installing local accounts and permissions on your nix box. Some wp files access others local files in real time which are mostly javascript libraries (JQuery and Ajax) which is why the menus and drag and drop functionality don’t work. The Folder that has just about all the js libraries is the wp-includes folder I would make sure you are handling your chmod permissions correctly for the type of setup your box has.

    The Solution:
    You will have to set your entire wp-includes dir (and child directories) 755 mod to 775 and your 644 to 664 (files) to allow application files to access other local wp files/resources. If in doubt, at least try setting the entire wp-include directory with group access (775 for folders and 664 for files) I am quite sure this will solve your problem.

    I hope this helps if not reply to this post, I will create a VM to replicate the problem and create a video explaining the solution more in depth.

    You can read more about chmod permissions and variant chmods at the wordpress codex or follow the link

    http://codex.wordpress.org/Changing_File_Permissions

    Regards,

    Thanks for this, xymantec, but … this is a Windows box not a *nix box. Nonetheless, I’ll try and turn what you’ve said into a Windows permissions investigation. There’s a couple of weird things, though:

    1. The installation directories work fine with WP 3.3 but fail with 3.4.2;
    2. I’ve got another Windows box that 3.4.2 DOES work on.

    Both the above are vanilla systems, clean installations.

    Watch this space,

    @jccurd

    You first problem is using a windows box lol… 😉

    lame jokes aside… Can you elaborate on you windows setup? are you using apache or IIS? which version of IIS? server or desktop OS, This will help me with trying to replicate the problem on a VM.

    Regards,

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘No menu drag and drop in 3.4.1’ is closed to new replies.