Support » Plugin: Powered Cache » No memcached option

  • Resolved kersianuy

    (@kersianuy)


    I was configuring the plugin, set the variables in wp-config,

    define( ‘WP_CACHE’, true );
    $memcached_servers = array( ‘default’ => array( ‘127.0.0.1:29014’, ‘127.0.0.1:29014’ ) );

    In cpanel already started memcached, the first time configuring the plugin I saw the option and configure all options, I notice my web slow down a lot and deactivated the plugin to see if would speed up and it did.
    Then tried to activate plugin again and the option was gone, tried to uninstall and reinstall and nothing.

    https://imgur.com/a/iSaI2aZ

    I really want to test this plugin to see if my page can speed a little, I have 128MB in memcache to use.

    Best regards.

Viewing 7 replies - 1 through 7 (of 7 total)
  • kersianuy

    (@kersianuy)

    I already tried to tick the first option and save but nothing.

    Plugin Author Mustafa Uysal

    (@m_uysl)

    Hi @kersianuy,

    It seems you don’t have PHP driver for memcache or memcached, so you can’t use that object cache backend on your hosting.

    WP_CACHE constant controls the page cache not object cache.

    kersianuy

    (@kersianuy)

    I do have memcache because litespeed or w3 cache connects to 127.0.0.1:29014 normally.

    Now I could config the memcache for this plugin, but if you can test in my site, add a product to cart and you go back to home the product dont display in cart you have to refresh or load other page, the same for second product and so..

    zookids.uy

    • This reply was modified 8 months ago by kersianuy.
    Plugin Author Mustafa Uysal

    (@m_uysl)

    I do have memcache because litespeed or w3 cache connects to 127.0.0.1:29014 normally.

    If the Memcached is running on the server, you can connect to 127.0.0.1:29014 but there is no available object cache on your server, which means you need to install proper PHP driver(s)

    I’m not sure Litespeed but w3tc also checks the Memcache(d) extension as I know.

    Now I could config the memcache for this plugin, but if you can test in my site, add a product to cart and you go back to home the product dont display in cart you have to refresh or load other page, the same for second product and so..

    It displayed on the homepage too. Possibly It’s related to page caching, if there is a specific cookie when adding an item to the card, you should ignore that cookie to serving cached page. (you can find options under the advanced cache tab)

    If you need documents, please check wiki pages: https://github.com/skopco/powered-cache/wiki

    I added this 3 cookies that are the one woocommerce uses for cart and the error keep.

    woocommerce_cart_hash
    woocommerce_items_in_cart
    wp_woocommerce_session_

    Don’t know what to si to fix this.

    Plugin Author Mustafa Uysal

    (@m_uysl)

    Hi @kersianuy,

    Is that work as expected when you turn off the page caching? Or you get this error while Memcached is enabled?

    Plugin Author Mustafa Uysal

    (@m_uysl)

    Hi @kersianuy,

    I’m marking this topic as resolved. Feel free to open again with some feedback.

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No memcached option’ is closed to new replies.