Support » Fixing WordPress » No media upload or media library in 4.9.6

  • Since 4.9.6 can’t upload media files the usual way. Get “Http error.” The media files are the same type and size I’ve uploaded to the site for the past five years and used to run like clockwork until yesterday. I can upload media only by leaving the post, going to Media Library, Add. Then the media uploads. But it’s unattached, and when I try to attach it to a post I get “An error has occurred.” The Media Library also no longer displays in grid mode.
    Also BTW the Plugins/Add function no longer responds to the “search” box. Can’t find and install a new plugin other than the “Featured’ and “Popular” items.
    I’ve deactivated any plugins and themes that had updates the same time as 4.9.6 with no improvement. Nothing has changed on the server.
    WP used to run really nice. Now suddenly it’s chaos. I want to rollback to 4.9.5, but don’t see an easy way to do it.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Moderator Steven Stern (sterndata)


    Volunteer Forum Moderator

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Thread Starter manicolaus


    Installed Health Check, probably identified BackWPUp as plugin causing problems. But then, after concluding check, while reactivating other plugins got this msg:

    Fatal error: Allowed memory size of 62914560 bytes exhausted (tried to allocate 12288 bytes) in /home/manicolaus75/public_html/cc/wp-admin/includes/post.php on line 1430

    and the site went blank. Dead. Can’t log back in. Site is white, nothing there. Now what?

    Thread Starter manicolaus


    After restoring from a backup db the site is back up.

    Moderator Steven Stern (sterndata)


    Volunteer Forum Moderator

    The lastest version (3.5.0) of BackWPUp is a bit funky. I had to roll back a couple of sites to 3.4.5.

    Probably you can reinstall the latest WP update version 4.9.6 and do the following steps as below:-

    1.Disable all the plugins and themes.
    2. Reinstall the WP updates completely.
    3. Install the plugin “Health Check” –>
    4. Enable the health check plugin and check for the issue, probably you’re running out of date php or database… if so, please try to update the PHP and your mysql database version which might be causing the compatibility issue.
    5. Enable all the plugins and after enabling the plugins if you’re seeing any fatal error it might be because of incompatibility of php or mysql database version. Try to update your php and my sql as mentioned in earlier step as well.
    6. after enabling all the plugins successfully, you are done and give a try to upload the files.. i hope it should work…

    Please let me know once you succeed or have any issues… All the best !!!

    • This reply was modified 5 years, 4 months ago by naveen1806. Reason: missing words

    Thanks @naveen1806 for the road map.

    We identified the problem: a function in our child theme functions.php template. This function was designed to hide the WP version and I believe many users may have implemented it as such :

    /* WARNING : DO NOT USE THIS - Breaks WP 4.6.9 JSON !!!*/
    function hide_version() { // hide WP Version
        return '';
    add_filter('the_generator', 'hide_version');

    Replacing this function with that single line solved the problem instantly :
    remove_action('wp_head', 'wp_generator');

    May help some people with a similar issue (or another function that messes with the headers); was a bit difficult to identify since it never produced unwanted/side effects before (but maybe this was a bad idea since day 1 … Another copy/paste that should have been avoided: my bad, bad, bad )

    • This reply was modified 5 years, 4 months ago by superflyfr.
    • This reply was modified 5 years, 4 months ago by superflyfr.
    • This reply was modified 5 years, 4 months ago by superflyfr.

    Had this same HTTP Error on image uploads – Fixed the issue by changing my PHP Configuration to 7.0 – No more issues.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No media upload or media library in 4.9.6’ is closed to new replies.