Support » Plugin: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) » No Marker Icons while creating a new Marker

  • Hi,
    I installed the plugin with XAMPP in Linux and everything is fine.

    When I installed the plugin live I can’t see any icon while creating a marker (example).
    I unzipped all icons into the directory ../wp-content/uploads/leaflet-maps-marker-icons – even the txt-file. I even changed the chmod to 777. Nothing.

    Could anyone please tell me what has gone wrong? I would appreciate it!
    Thx,
    CC

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author RobertHarm

    (@harmr)

    please reset the plugins default settings – I think this could solve the problem (the marker icon directory gets saved when first installed and might need to be changed when moving WordPress)

    Hello, I have the same problem.
    I did reset to default settings, I have txt file inside wp-content/uploads/leaflet-maps-marker-icons, but there are no icon visible when I want to add new marker.
    If I want to use tool to “Change settings for all 1 existing marker maps”, icon section working properly. and I can change icon, but only for all object in layer.

    Plugin Author RobertHarm

    (@harmr)

    Hi,
    please upgrade to the latest version first.
    regards,
    Robert

    Hi,
    Thank you for your advice. Unfortunatelly I believe I have latest version, because it says version 3.5.2 in installed module list, see picture: http://s4.postimage.org/pr664b08d/Snap_2013_02_15_at_09_09_42.png But in module it sais this: Maps MarkerĀ® v2.3 http://s8.postimage.org/icc7a5k2t/MAPSmaker.png
    Basically I installed your plug in (icons did not work) yesterday, then I did upgrade of WordPress (icon did not work), then I tried to uninstall module, and delete files, then install it again, it did not work neither.

    Interesting thing is, that I can see and choose icon in tools option.

    thank you for your amazing work with this plugin!

    Martin.

    Plugin Author RobertHarm

    (@harmr)

    Have you deleted the plugin files manually or through the general WordPress plugin uninstall function? If not, please uninstall via built in function and install again.
    I am not quite sure – could be some directory permission issues. Or low php memory limit…

    Yes, I uninstalled it vie built in function.
    I look at php code, and I found problem. Variable $current_editor is not returning any value… So in the file leaflet-marker.php I just commented condition on line 523:

    } else /*if ($current_editor == 'advanced')*/ {

    My problem is, that there is no option in database with name: leafletmapsmarker_editor

    Now it is working for me…

    I did not go deeper because of lack of my time.
    Thank you for your free time, support and help.

    Martin

    Plugin Author RobertHarm

    (@harmr)

    strange – this option normally gets added when updating/installing the plugin. Havent heard any other troubles with this yet so I guess something specific on your site went wrong…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No Marker Icons while creating a new Marker’ is closed to new replies.