Support » Plugin: 12 Step Meeting List » No map produced for new entries

  • Resolved theronb

    (@theronb)


    We are using Mapbox, been working fine until today. Two new meeting entries now do not show the specific location map, just the entire world. Existing meetings are still okay. We have a custom Mapbox API key. The only change today that I know of was that I ran some plugin updates, including The Events Calendar Pro, which we use for other kinds of events. EC Pro requires a Google Maps key, can’t use Mapbox. I tried deactivating the EC Pro plugin but that did not restore the Mapbox maps in 12 Step Meetings.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author tech2serve

    (@tech2serve)

    I agree with your logic to deactivate other plugins, and that is where I would have started as well. But since that didn’t seem to help, I think we should look at this from a different tact.

    Are these two new meeting entries at the same address? What are the addresses?
    What version of the plugin do you have installed?

    Thanks for the quick response. I deactivated nearly all of the other plugins, except the firewall, and that didn’t correct the problem. The two new entries do not have the same address. The addresses are: 2025 NE Martin Luther King Jr Blvd, Portland, OR 97212, and 433 NE 76th Ave, Portland, OR 97213, USA. Nothing particularly odd there.

    The edit screens for these meetings show no map at all; the preview screens show a world map with no location pins. We have version 3.5.0 installed. Still puzzled.

    Not sure this has any bearing on the problem, but our office manager, who does all the Meetings updates passed this along:

    “On a previous update there was an are where we could toggle map features. It is not there now unless there is a higher level of admin that we are not signed into?
    Maybe we need a new api key for mapping?”

    I did double check the Mapbox API to make we had a valid key.

    Plugin Author tech2serve

    (@tech2serve)

    I’m still trying some different tests to reproduce what you’re seeing, but no luck. When I use those addresses to add a new meeting to my test database, everything works fine.

    What firewall are you using? Is that a plugin? If so, please try disabling it and adding the meeting with the address in question.

    Please confirm what role in WordPress you have assigned your office manager. I’m using “editor” for my tests. With Editor, you shouldn’t see the Import & Settings menu option, only the selections for managing meetings.

    I tried deactivating the firewall (WordFence) and that didn’t make any difference. It occurred to me that I should try entering a new meeting – maybe there was something defective (?) with the two we were having problems with. I entered a new meeting and the map came up just fine. I re-activated the firewall and the new meeting’s map was still good. I checked the two problem meetings and the maps were still not working, so I deleted them and re-entered with the same information and now they are working fine.

    The office manager’s account has Admin access because it’s just the two of us and it’s not good for me to have the only Admin account, in case I get hit by the pie truck.

    So guess you can close this ticket, although I have no idea how it was solved. Thanks for your support!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.