Support » Plugin: Simple Shortcode for GoogleMaps » No map: OVER_QUERY_LIMIT for geocode API

  • Resolved Alex Mansfield

    (@alexmansfield)


    It took me quite a while to track down what I think is the root of this issue. Maps are working locally but not on the live server. Code was the same both places. I tried disabling all plugins and using the default theme, but that didn’t help. I followed the data flow through the plugin, and it appears to be failing within the pw_map_get_coordinates() function. The call to the Geocode API fails with an OVER_QUERY_LIMIT error (line 115 of the main plugin file). Could it be related to the fact that the plugin doesn’t pass the key requesting coordinates from the API? It only passes the key on the second API call, which is for the map itself.

    I really don’t know what’s going on with this, but I tried to follow it as far as I could. Any ideas?

    To find the actual error message, I added this below line 145:
    ‘echo $data->status;’

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No map: OVER_QUERY_LIMIT for geocode API’ is closed to new replies.