Support » Plugin: Events Manager » No map anywhere

  • Resolved Abracarambar

    (@abracarambar)


    Hello,
    I followed all the tips explained in this post (https://wordpress.org/support/topic/map-unavailable-5/), but I still can’t see any result of the adresses I fill for the events, only “Map unavalaible”.
    The adresses are true in Googlemaps.I don’t have any activity in Google Cloud platform.
    I don’t know what to do. All API are activated, no restriction for troubleshoot.
    The API key is on the backoffice of the plug-in and activated.
    I have just a doubt. When I copy/paste the API key from ggl, it add a space before the API key in the field of the event backoffice, even selecting all in the field before pasting. I tried with and without the space, that’s changing nothing.
    I have another question : does I have to make a new place to test each time I change a parameter ?
    Thank you.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support caimin_nwl

    (@caimin_nwl)

    Hi,

    Are you seeing the maps in admin?

    It’s possible this is a conflict caused by your theme or another plugin. To check if it is, can you test with all other plugins deactivated and while running the default WordPress theme?

    Thread Starter Abracarambar

    (@abracarambar)

    Hello,
    Thanks for your answer.

    Yes I tried with twenty sixteen and no other plug-in.

    I don’t see any map, in FO and BO.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    Are you seeing any errors in your Google Maps API Console?

    Thread Starter Abracarambar

    (@abracarambar)

    I have no error on GMAC,
    I can notice there is no trafic at all.

    The parameters in Google Cloud Platform :
    API Activated : Google Maps Javascript API, Google Maps geocoding API, Google Places API Web Service. The key is activated with no restriction at all.

    Another thing to note : I use the same key to produce a playlist of my youtube channel for this website too with the help of Youtube Data API v3. And it works fine.

    But still no map.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    You need separate keys for the two services, you can’t generate a key for one service and use it for another.

    Can you generate a new Maps API key and try that?

    Thread Starter Abracarambar

    (@abracarambar)

    Ok,
    so I separate them.
    I made a new API key and referred to the 3 APIs : Google Maps Javascript API, Google Maps geocoding API, Google Places API Web Service

    and it works.

    So I tried to make http referrer : *.juricmusic.com/*
    and I have a new problem, I have a shoot of javascript : It can’t accept the referrer, it’s false…I don’t understand.

    So I gone back to refering to the APIs and it’s working again.

    One of the most important problem is, it’s necesary to make a new place in the plug-in to see it working, and so remake all the “bugging” places, each time you make important changes in the API platform, to make it working.

    Ok it’s working but not secure at all.

    • This reply was modified 3 years, 7 months ago by Abracarambar.
    Plugin Support caimin_nwl

    (@caimin_nwl)

    Can you explain what you mean by

    I have a shoot of javascript : It can’t accept the referrer, it’s false…I don’t understand.

    ?

    Thread Starter Abracarambar

    (@abracarambar)

    When I add an http referrer for the key, Javascript console answers : the referrer is wrong.
    Here is the referrer : *.juricmusic.com/*, I tried adding juricmusic.com/* and *.juricmusic.com, still wrong.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    The correct format is:

    *.juricmusic.com/*

    What happens when you try that? I’m able to add exactly that to my API console and have it save correctly.

    I would save that in your API, then wait a few hours for the API to update properly. If you’re still not seeing maps, do the theme and plugin test again.

    maybe I forgot to add *. and/* at the beginning and end of the url. i will try that.

    Thread Starter Abracarambar

    (@abracarambar)

    Hello again, when I try this, maps stops working. Nothing else.

    Plugin Support caimin_nwl

    (@caimin_nwl)

    Can you post the exact URL you’re adding when it stops working?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘No map anywhere’ is closed to new replies.