Support » Plugin: Popup Maker - Popup Forms, Opt-ins & More » No longer works with WP 5.5

Viewing 1 replies (of 1 total)
  • Plugin Author Daniel Iser

    (@danieliser)

    @tonycreative – Sorry to hear you had issues with the latest version of WP, but I can assure you our plugin works perfectly fine on a clean install. We tested all the betas before they came out and used the Test jQuery Updates plugin created by the WP core team to test the upcoming JS updates. We have not identified any issues at any of the stages of that future upgrade process either.

    What I can tell you though is that WP 5.5 removed jQuery-Migrate by default. You can enable it again with a plugin.

    This is important because not all plugins & themes were fortunate enough to not have issues with this change. Again we have no issues with these changes.

    BUT, if another plugin didn’t update properly their code could now be throwing fatal JS errors which absolutely could cause our code to never even get to run.

    Thus another plugin/theme’s code is likely breaking our popups, not the other way around.

    Try this guide to find the issue, likely the JS issue still exists even if you deactivated our plugin. If its something like a theme’s code you may not even notice it is broken except when it interferes with another plugin like ours.

    https://docs.wppopupmaker.com/article/373-checking-javascript-errors

    Hope that helps. But you can verify this by checking over the forum tickets, there are not hundreds (if not 1000s) of tickets and responses as you would expect if it just simply didn’t work on the latest version.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.