Support » Plugin: Elementor - Header, Footer & Blocks Template » No longer working with Polylang multilingual plugin

  • Resolved alarch

    (@alarch)


    A bilingual website I’ve been working on was displaying footers created in the two languages with Elementor – Header, Footer & Blocks in the appropriate language. This is in conjuction with the popular Polylang multilingual plugin. However, now only one language version of the Elementor footer block is displayed irrespective of the language selected to show on the front-end. I believe this is change has been caused by a recent update to the Elementor – Header, Footer & Blocks plugin.

    Note that the “Headers Footers template” tickbox has been ticked in the Polylang settings – which activates languages and translations for custom post types.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 16 through 28 (of 28 total)
  • Thanks for the good news.

    Hey @brainstormteam, just wanted to report that this last update created the issue in this thread for our website (which was not present before), I reverted to the previous version, and now it is working with polylang and polylang elementor connect well now (as it was prior to the update). Just thought to bring this to your attention, please let me know if I can provide more information about this.

    Best regards,

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @ajbattah,

    Thank you for getting back!

    Could you please provide us a few more details about the issue so that we can check at our end?

    Looking forward to resolving your issue ASAP.

    Regards,
    Prajakta

    Yes sure @brainstormteam, so we updated the header footer plugin (about 6 days ago I’d say). A couple days ago we noticed that all the components we built with the plugin (so header and footer for our whole website http://www.smartmile.eu) are no longer visible as if it would’ve deactivated the plugin/override. When deactivating the Polylang plugin however, the components would comeback (unaffected by the polylang elementor connect plugin). I reverted back to the previous version of your plugin and then it worked again (components came back as they were before the update, without issues)

    • This reply was modified 5 months, 1 week ago by ajbattah.
    • This reply was modified 5 months, 1 week ago by ajbattah.
    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @ajbattah,

    Thank you for getting back to us!

    This has been fixed in EHF v1.5.3. Could you please update EHF to the latest version and confirm if the issue is resolved?

    Please do not hesitate to get back to us if you still face the issue.

    Hey @brainstormteam, I just updated to 1.5.3 and it works fine! Thank you for your prompt responses and the quick fix.

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @ajbattah,

    Thank you for getting back to us!

    I am glad that the issue is resolved now. Please do not hesitate to contact us in case of any other assistance you may need.

    Have a great day ahead!

    Regards,
    Prajakta

    Hi,

    I am having still issues with my footer.
    I have Elementor, the Elementor Polylang connector tool, Polylang and your plugin.

    I activated your plugin inside Polylang, but once I add a footer for my 2nd language, it only shows that language, doesnt matter what language you choose on my website. Did I forget to configure something?

    • This reply was modified 4 months, 1 week ago by shevychase.
    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @shevychase,

    Thank you for getting in touch!

    Could you please open a support ticket through our support portal so that we can take a closer look?

    Looking forward to resolving your issue ASAP.

    Regards,
    Prajakta Suryawanshi

    Hi,
    I have the same issue on my site (still under construction)… I have used the workaround as suggested above (deactivate “Custom post types and taxonomies” and tell the footer/header to display on specific pages from Appearance > Header Footer & Blocks Template > Edit > Type of template)…however, I will post my blog posts on 3 languages, so I will need to do this workaround for every single block post … 🙁
    Do you know whether:
    a) there is another option meanwhile or
    b) is there a limit of pages/posts you can add as specific pages? Don’t want to run into the issue that after a certain number of posts this workaround has reached its limit …
    Thanks
    Silja

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @skretz,

    Apologies for the delay in response!

    This is really strange. If you have separate headers/footers for different languages, those should work fine with EHF. Could you please confirm once if you are following the same process as explained in the video? — https://share.getcloudapp.com/nOukZ2Rg.

    If this does not help, then we will need to debug this case. I will recommend you to open a ticket to our support forum in this case so that we can take a closer look at this.

    Looking forward to resolving your issue ASAP.

    Regards,
    Prajakta

    Hi Prajakta,
    Thanks for your message. I have disabled the header footer Template now completely and am going simply with customized messages directly managed in wordpress.
    Thanks
    Silja

    Plugin Support Team Brainstorm Force

    (@brainstormteam)

    Hello @skretz,

    Please do not hesitate to get back if you wish to use the custom header/footer again. We will be happy to help.

    Have a great day ahead!

    Regards,
    Prajakta

Viewing 13 replies - 16 through 28 (of 28 total)
  • You must be logged in to reply to this topic.