WordPress.org

Forums

FireFly Effect on WordPress
No longer working in WordPress? (4 posts)

  1. Sam Lowry
    Member
    Posted 2 years ago #

    Until I recently upgraded to 3.5.2, I was using the following code without problem:

    <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>
    	<script type="text/javascript" src="https://raw.github.com/motyar/firefly/master/jquery-firefly-0.2.js"></script>
    	<script type="text/javascript">
    		$(document).ready(function() {
    			$.firefly({
    				images : ['http://myimagegoeshere.png'], 	//Fly images
    				total : 1, //number of flies
    				ofTop :390
    			});
    		});
    	</script>

    This is no longer working. Any ideas?
    Thanks

    http://wordpress.org/extend/plugins/firefly-effect-jquery/

  2. dreamstone
    Member
    Posted 2 years ago #

    I'm using it without problem at current version of WP 3.5.
    Try to disable coexisting plugins, maybe there is a conflict between FireFly Effect and some of your plugins.

  3. Sam Lowry
    Member
    Posted 2 years ago #

    Hi again-
    I discovered that I could no longer include the code above in the header as I previously did. So... my question is how to get my custom changes to override the defaults.

    I added <?php firefly_wp_setup(); ?> to a template page and I get the firefly effect as the author intended, but I'd like to use my art. I am not a php master. Please help.

    Thanks,
    SL

  4. Sam Lowry
    Member
    Posted 2 years ago #

    I'm back. Hopefully with a bit of documentation, others won't need to go through what I have.

    I discovered I could add my code to the jquery.firefly-setup.js file in the plugin so that the code looks like:

    jQuery(document).ready(function() {
    	jQuery.firefly({
    	images : ['http://www.123.myimage.png'], 	//Fly images
    	total : 1, //number of flies
    	ofTop : 390,
    	on : '#container'
    	});
    
    });

    The final problem was that the "on" option is getting ignored by all browsers I've tried. It worked outside of wordpress (using Responsive theme), but not working here. I wanted the image to behind all other elements on page (background). So I opened up jquery.firefly.min.js and changed
    z-index':$.firefly.random(20), to z-index':-1,

    If there is a fix for the "on" option please let me know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • FireFly Effect on WordPress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.