WordPress.org

Support

Support » Plugins and Hacks » No longer working and site load increased

No longer working and site load increased

  • Love the plugin, been using it for months.

    But it’s no longer working, about the time I upgraded WordPress to 3.8 I think.

    It’s also adding 4 seconds to my site’s load time, so I checked it on webpagetest.org. It looks like these elements are unable to load:

    /image-zoom/core/load-styles.php
    /image-zoom/core/load-scripts.php

    It first tries to load them and gets 301 errors. Then it tries again and gets 404 errors. It happened on my old webhost as well as my new one. Any ideas? I haven’t changed my plugins or theme.

    http://wordpress.org/plugins/image-zoom/

Viewing 15 replies - 1 through 15 (of 30 total)
  • Plugin Author Sed Lex

    @sedlex

    Work very well on WP3.8 …
    What is you URL so that I could test ?

    Wow thanks for the quick response 🙂

    I tried the tests again and I don’t even see it trying to load those files anymore. The plugin still isn’t working.

    tiptopsecurity.com

    URL with some images:
    http://tiptopsecurity.com/how-to-securely-wipe-your-hard-drive-with-dban-erase-your-data-for-good/

    Plugin Author Sed Lex

    @sedlex

    There is my plugin running but the loading url is very very strange …
    https://tiptopsecurity.com/tts-content/plugins/home4/rcjhood/public_html/tts-content/plugins/image-zoom/core/load-styles.php
    instead of
    https://tiptopsecurity.com/tts-content/plugins/image-zoom/core/load-styles.php

    Plugin Author Sed Lex

    @sedlex

    ohh …
    You have migrated to an other hoster ?
    That may explain if you migrate your site incorrectly

    Ok, that’s where it installed when I uninstalled/reinstalled the plugin. Looks like a mix of my old host’s and new host’s html directories.

    Image zoom is the only thing in that directory at all. Wonder why it installed there.

    So in theory if I just move those files into the right directory it should work?

    Plugin Author Sed Lex

    @sedlex

    No I believe that your old directory is hardly stored somewhere in the database or in the conf file …
    Thus, when my plugin create the url of the JS / CSS to be loaded, the behaviour is erroneous …
    $url = plugin_dir_url("/").'/'.str_replace(basename( $this->path),"",plugin_basename($this->path)) .$name ;

    The plugin is not installed in that directory but he believe he is

    Okay, I uninstalled the plugin, completely deleted that home4 directory and reinstalled. I see the plugin folder in the right place now but it’s still looking in that old directory for the files.

    So now I have to find why it’s trying to look in the wrong place. Could it be a caching problem?

    Plugin Author Sed Lex

    @sedlex

    The home4 directory exists ? stange …
    what is the normal complete path to the plugin dir ?

    home4 was part of the directory path at my last webhost.

    All my other plugins install correctly in /tts-content/plugins/. Image zoom was the only one in that home4 folder for some reason.

    It seems to be installing in the right place now, but it still doesn’t work. It may be I just need to update the cache or something.

    Plugin Author Sed Lex

    @sedlex

    You have a cache plugin ?
    empty cache / deactivate ?

    Plugin Author Sed Lex

    @sedlex

    Could you confirm that in the wp-config.php file you have this line ?
    define('ABSPATH', dirname(__FILE__) . '/');

    Yes, I do have that line.

    Correction… home4 is THIS webhost, not my old one. Sorry about that. So I don’t know why it created that wacky directory.

    I’ve disabled my cache plugin (WP Super Cache) and waiting to see if that works.

    Plugin Author Sed Lex

    @sedlex

    If it work that should be instantaneous … If not I will need an access to your website (FTP and WP account)
    You could sent me the credential by the feedback tab in the plugin

    Thanks for your awesome help on this! Getting closer I think.

    The cache is deactivated.

    Image Zoom is installed in the right plugin directory with all my other plugins.

    webpagetest.org is not getting any more 404s – it’s finding both those files now.

    But the plugin doesn’t work when I visit the page.

    I’d rather not give out my login info. You’ve been very helpful so far! I’m just not comfortable giving out that information to anyone.

    Any idea where else it might be getting that strange directory from? I noticed that those image zoom files are the only ones on the page besides google’s that are trying to load with a secure connection.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘No longer working and site load increased’ is closed to new replies.