Support » Plugin: Contact Form Clean and Simple » No longer seems to work

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hi Xamaba, I’m a fellow plugin user (not author or anything).
    Can you provide a screenshot of the error? Did you recently update any plugins (especially this one) or add any new ones or change themes?

    I am having the same problem all of a sudden. Upon completion of the CAPTCHA form and then attempting to submit, one will receive a message that the reCAPTCHA must be tried again even though the green check box comes up as verified accurate. It will continue to say “Please solve the recaptcha to continue.” and will not submit the message.

    @sniedzwiecki can you share your site where you’re having the issue?

    FYI – I went back to Google and made a new key, etc. and nothing is changing in terms of the form submitting. Thanks for looking into this.

    On Google’s side it is saying “We detected that your site is not verifying reCAPTCHA solutions. This is required for the proper use of reCAPTCHA on your site. Please see our developer site for more information.” – even if a brand new key is put in place.

    The plugin uses a PHP function called file_get_contents() to confirm with Google that you successfully answered the Recaptcha, and it seems that function isn’t working for you. (https://stackoverflow.com/questions/27613432/file-get-contents-not-working has some explanation of why not).

    @sniedzwiecki do you have access to your server’s php.ini file? If so, you need to make sure the setting allow_url_fopen is set to On or 1. I suspect it’s currently set to Off or 0.

    Another solution involves making a code change.

    @megnicholas I would suggest changing the current implementation of csf_RecaptchaV2::SubmitHTTPGet() to be

    static function SubmitHTTPGet( $path, $data ) {
    			$req      = self::EncodeQS( $data );
    			$response_obj = wp_remote_get( $path . $req );
    			$response = wp_remote_retrieve_body($response_obj);
    			return $response;
    		}

    notice it’s usingwp_remote_getinstead offile_get_contents(). I foundwp_remote_getworks even when I haveallow_url_fopen=Off.

    • This reply was modified 2 days, 18 hours ago by  Michael Nelson. Reason: fix formatting errors
    Plugin Author megnicholas

    (@megnicholas)

    Thank you @mnelson4. I will look into changing this in the next update.

    Great, thanks!

    Thank you so much. I think this may be a bit above my skill level, however.

    Just curious – this had been working up until the past week or so… what would have suddenly changed in this regard? Was there a recent update, @megnicholas?

    Kindest regards,
    Stacy

    Plugin Author megnicholas

    (@megnicholas)

    Hi @sniedzwiecki)

    The plugin has not been updated recently. But possibly there has been a change on your host server that has caused this. I often receive support tickets from users who say that the plugin has suddenly stopped working and often it is server changes that are the cause.

    Your host should be able to help with the php.ini file update.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this review.