WordPress.org

Forums

[resolved] No longer can log into my blog. (18 posts)

  1. Adrenaline416
    Member
    Posted 3 years ago #

    When I go to my Admin login page and try to log in, the page comes back with this:

    Fatal error: Call to undefined function wp_menu_unfold() in /home/content/A/d/r/Adrenaline416/html/mtmstudios/blog/wp-admin/admin-header.php on line 15

    I haven't edited my web hosting site or anything, it's worked fine for 2 years and now this fatal error out of nowhere. Please help!

  2. NateJacobs
    Member
    Posted 3 years ago #

  3. Adrenaline416
    Member
    Posted 3 years ago #

    I found the location of the apparent undefined function: "wp_menu_unfold()"

    Fatal error: Call to undefined function wp_menu_unfold()......on line 15

    But I don't know what to change this to in order to make it work again.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    There is no wp_menu_unfold() function in WordPress itself. Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  5. Adrenaline416
    Member
    Posted 3 years ago #

    I'm looking through the instructions to see how to do some of those things. I'm the most un-savvy person at web coding and all that, so it's confusing to me. I'll try to disable the plugins folder via FTP by following the instructions.

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Also try switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

  7. Adrenaline416
    Member
    Posted 3 years ago #

    I tried the resetting the plugins folder as well as changing the name of my "themes" folder to "themes-old" but neither worked and I still get the same fatal error line when I try to log in to my admin panel. Might try manual upgrade next but it looks a little confusing on the extended instructions.

  8. esmi
    Forum Moderator
    Posted 3 years ago #

    as well as changing the name of my "themes" folder to "themes-old"

    No one told you to do that! Change it back and please re-read what was posted.

  9. Adrenaline416
    Member
    Posted 3 years ago #

    Yes I saw that mistake and corrected it. I changed my current theme from "tomorrow" to "tomorrow-old" but it still didn't work.

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    Do you have an unedited copy of the Twenty Eleven theme in your wp-content/themes folder? If you're not sure, upload a fresh copy of that theme using FTP.

  11. Adrenaline416
    Member
    Posted 3 years ago #

    Yes I see it in there and I've never messed with it.

  12. esmi
    Forum Moderator
    Posted 3 years ago #

    Nevertheless, try re-uploading a fresh copy.

  13. Adrenaline416
    Member
    Posted 3 years ago #

    I did the manual upgrade and I can now log into my admin panel. However, now my actual blog page is blank (just a white background). I followed the instructions to the letter to the best of my knowledge.

  14. esmi
    Forum Moderator
    Posted 3 years ago #

    Ok - now we're getting somewhere. It sounds like you have some file corruption problems. Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  15. Adrenaline416
    Member
    Posted 3 years ago #

    I did that via the manual upgrade. I downloaded the latest version (3.2.1) and replaced all the loose .php files, the wp-includes folder and the index.php file inside the wp-config folder (the other folders were plugins and themes and I did not replace those per the instructions). I uploaded those into my root directory and that's where I am now. Admin login ok but no more blog.

  16. esmi
    Forum Moderator
    Posted 3 years ago #

    Do you have access to your server's error logs?

  17. Adrenaline416
    Member
    Posted 3 years ago #

    I don't know what that is. I'm using Dreamweaver for the ftp.

  18. Adrenaline416
    Member
    Posted 3 years ago #

    Found it- I still had my theme "tomorrow" named "tomorrow-old". Thanks all is working now, appreciate the help.

Topic Closed

This topic has been closed to new replies.

About this Topic