WordPress.org

Forums

No longer can access my wp-admin (5 posts)

  1. Cmoore465
    Member
    Posted 2 years ago #

    HELP!
    I have been working in wordpress for about a week with a new theme on the backside of my site cmoorecreative.com/wordpress. Everything was good and I had the design where I would like it. I wanted it to go live and replace my cmoorecreative.com site with the wordpress. I was reading the forums and it said to go the the general tab and point wordpress from cmoorecreative.com/wordpress to cmoorecreative. (Did it) Using a text editor change a line towards the bottom of the index.php (Did it) copy the index.php and the .htaccess file to the root directory.(Did it). Luckily I backed up my site before I did any of this. When you type in the address it comes up with a fatal error. The next step was to go in and change the permalinks. I went to go in and log in to cmoorecreative.com/wordpress/wp-admin and it takes me back to the old sites home page.

    Now when you go to cmoorecreative.com/wordpress it shows the text but the theme is missing. I am sure if I could go back and change the general settings back it would work but don't have access to it anymore. Need some help with this one, not sure what I did wrong.

  2. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    We want to help, so please follow all links and if not understood, reply.

    Do you have FTP access to this site?

  3. fonglh
    Member
    Posted 2 years ago #

    Change the URL settings back with these instructions.
    http://codex.wordpress.org/Changing_The_Site_URL

    Follow the directions on this page exactly.
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  4. Brandon Kraft
    Happiness Engineer
    Posted 2 years ago #

    As for why cmoorecreative.com/wordpress/wp-admin is directing you to cmoorecreative.com/Home.html, there is some .htaccess (or similar) rule in your root directory doing it.

    cmoorecreative.com/wordpress/wp-admin is directing you to the /wp-login.php file (which, because of the settings change, thinks is in root at cmoorecreative.com/wp-login.php)

    Notice that http://cmoorecreative.com/wordpress/wp-login.php works (minus theme).

    It sounds like you need to remove/edit the .htaccess file in the root directory and using the http://codex.wordpress.org/Changing_The_Site_URL instructions to change the Site URL back to /wordpress/.

    Then, as fonglh pointed out, follow those directions to change the Home URL (not Site URL) to root & copy/modify index.php.

  5. Cmoore465
    Member
    Posted 2 years ago #

    THANK YOU!!! Thought I was going to have to start from the beginning again. Used the second option where I edited the functions.php and it worked back to where I was originally and everything works. Now for the second attempt at replacing my old site with the new one. Thank everyone for responding with the right solution.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.