Support » Plugin: Events Made Easy » No longer accepting reservations

  • Resolved graftedin

    (@graftedin)


    We’ve been trying to track down a weird error that seems to only happen to some users. It says something like “The message says no longer accepting reservations” but the event still has spots open. It works fine every time I test it. However I did manage to kick up an error while I was logged in as an admin when I tried to register using a different email address…..it told me I couldn’t do that.

    I don’t have direct contact to the people registering because this is my client’s site.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Franky

    (@liedekef)

    Are you sure this is EME? “No longer accepting reservations” is not a message that EME generates, but maybe it is generated by using conditional tags in the RSVP form?
    Also it seems weird you would not be able to register when logged in. When you empty the form, you can rsvp as anyone then … If you can reproduce that, let me know.

    The exact wording of the error is not known. But your RSVP/Reservation part of your plugin should block registrations after the event is full and display some type of a message.

    I think that this may be a timing issue. She mentioned after I first posted this question that it wasn’t letting them register 15 minutes before the event. I have it set to 0 minutes before the event so that shouldn’t happen.

    Plugin Author Franky

    (@liedekef)

    By default EME allows registration until the start of the event, so if people have it set at something else … but the accuracy is days and minutes for the option “Allow RSVP until”, not minutes.

    I have confirmed it seems like a time based problem. Its now 17:25ish and I’m trying to sign up for an event at 6:15 pm of the same day and it says “You’re not allowed to do this. If you believe you’ve received this message in error please contact the site owner.” The event at 7:30 will let me sign up.

    I have confirmed that the time zone settings in wordpress are correct.

    Plugin Author Franky

    (@liedekef)

    Can it be that the time on that server is wrong? I’m unable to reproduce it here … which timezone are you in (I’ll switch my test wordpress to that zone and try again)?

    Both the server and wordpress are set for Central (Chicago). If you’ve got a way for me to contact you I can get you access to the site.

    Plugin Author Franky

    (@liedekef)

    If it is a start time issue, the default EME message is “Bookings no longer allowed on this date” and the form no longer shows. Just tested it here with your timezone too.
    I’m guessing that in your case the form is still showing, meaning that EME still allows people to sign up. However, if you have a caching plugin in place, that might be the cause: they can cache forms that are protected by wordpress nonces and cause the nonce to be expired already (by showing the cached version). Do you have a caching plugin in place?

    There’s no cache.

    Plugin Author Franky

    (@liedekef)

    Then please provide a test example where you can reproduce the problem, so I can take a look at it. You can always email me the procedure to reproduce to liedekef@telenet.be

    Plugin Author Franky

    (@liedekef)

    Any luck reproducing it?

    The problem is I don’t know necessarily how to reproduce it outside of my instance. If you are ok with it I’d prefer to just email you access to the site and I can tell you on the site how to reproduce. I won’t have time to do this until Monday though.

    Just a random thought…..its probably in your documentation but what php version does your software need/support? I have some older sites that still need 5.5 but have been upgrading sites as needed. Maybe this is a php issue and it needs to be 7+?

    Plugin Author Franky

    (@liedekef)

    It is indicated that EME needs php 7.0 or higher (although that part should not be influenced, but some parts of the code might be incompatible). Also mysql versions older than 5.6 are not supported either (5.5 is long end-of-life).
    Feel free to email me anything you like, but if the site doesn’t meet those requirements I’d first suggest to upgrade.

    I updated to php 7.3. MySQL is at 5.6. Our version of your plugin is a few behind so I’ll update that Tuesday and then see if I can recreate. Otherwise I’m hoping to have time to get in under the hood and see if I can find where this is not working.

    Plugin Author Franky

    (@liedekef)

    Have you had any luck recreating the issue?

    I got the plugin updated yesterday. Emails were also not being sent and I discovered that the smtp was turned on but with no settings……the client might have done that. I’ll let it run for a few days and see if more issues come up.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.