Support » Plugin: GDPR Cookie Compliance » No Livezilla button after Cookie acceptance

  • Resolved SchweizerSchoggi

    (@schweizerschoggi)


    Hi,
    we have all cookies disabled when user arrives at our page.
    If he accepts cookies, all the relevant cookies should be set.

    This does not seem to work, as for example the Livezilla chat button does not appear afterwards.

    Can you please give me a hint, what I am doing wrong? For me it seems that the page reload is currently missing.

    Or is the plugin only working the other way around (cookies accepted by default and disabled by user button click)? That works for us, but because of legal reasons we have to build it as stated before (disabled first, then activated after user acceptance)

    Any help would really be appreciated

Viewing 7 replies - 1 through 7 (of 7 total)
  • Tested it again: Accepted Cookies, reloaded the page manually this time. Livezilla button did not show up. WHY?

    Plugin Author Moove Agency

    (@mooveagency)

    Hi @schweizerschoggi,

    Thanks for using our plugins.

    You can try to add the following code snippet to your functions.php:

    add_action( 'gdpr_force_reload', '__return_true' );

    By this once the user accepts the cookies, the page will be reloaded (exception when the accept cookies on scroll is enabled, the Livezilla chat will be available in the next page)

    Hope this helps.

    Thank you, page reload does work now. But unfortunatly Livezilla does not show up at all.

    I have included its Script to the footer section of 3rd party cookies like this:

    <script type=”text/javascript” id=”2762f3604a9ec5a74ada11111111111″ src=”//staging.xxxxxxx.net/livezilla/script.php?id=2762f3604a9ec5a74ada11111111111″ defer></script>

    Is this wrong?

    Plugin Author Moove Agency

    (@mooveagency)

    Hi @schweizerschoggi,

    You can try the following script:

    <script type="text/javascript" id="2762f3604a9ec5a74ada11111111111" src="https://staging.xxxxxxx.net/livezilla/script.php?id=2762f3604a9ec5a74ada11111111111"></script>

    The change between the original and the current one is the “defer” tag is removed and added the https://staging.xxx instead of //staging.xxx

    If still not working, please let us know the site URL to check the conflict.

    Thanks

    Plugin Author Moove Agency

    (@mooveagency)

    Hi @schweizerschoggi,

    We have checked the staging site and it seems the problem is coming from the script source, as it’s a script.php used as src and not a direct .js file.

    You can try to fix the issue by adding the following code snippet to your functions.php and follow the steps below:

    1. Remove the LiveZilla script from the ThirdParty scripts in GDPR settings
    2. Add the following code snippet to your functions.php

    add_action('wp_footer','gdpr_livezilla_sample');
    function gdpr_livezilla_sample() {
      if ( function_exists( 'gdpr_cookie_is_accepted' ) ) {
        if ( gdpr_cookie_is_accepted( 'thirdparty' ) ) {
          ?>
          <script type="text/javascript" id="2762f3604a9ec5a74ada11111111111" src="https://staging.xxxxxxx.net/livezilla/script.php?id=2762f3604a9ec5a74ada11111111111"></script>
          <?php
        }
      }

    Hope this helps, please confirm if it’s working as expected.

    Thanks

    I’ve seen your answer just now – going to test it immediateley!

    IT WORKS !!!!
    You’re brilliant!

    OMG, I would never ever have found a solution for this problem.
    Thanks a lot for takting the time looking that deep into it!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘No Livezilla button after Cookie acceptance’ is closed to new replies.