Support » Plugin: WP YouTube Live » No live streaming

  • I’m trying to live streaming in this page but I can’t. If I click the “all of our videos” link I am redirected to a blank youtube channel. I’m streaming right now.

    <!-- YouTube Live debugging: 
    EmbedYoutubeLiveStreaming::__set_state(array(
       'channelId' => 'UCbYtiqpPtQjL3-U07v230Aw',
       'API_Key' => '',
       'jsonResponse' => '{
     "kind": "youtube#searchListResponse",
     "etag": "\\"XI7nbFXulYBIpL0ayR_gDh3eu1k/E4HxAVVo5-NQgTdQI4YY5CueOXk\\"",
     "regionCode": "IT",
     "pageInfo": {
      "totalResults": 0,
      "resultsPerPage": 5
     },
     "items": []
    }
    ',
       'objectResponse' => 
      stdClass::__set_state(array(
         'kind' => 'youtube#searchListResponse',
         'etag' => '"XI7nbFXulYBIpL0ayR_gDh3eu1k/E4HxAVVo5-NQgTdQI4YY5CueOXk"',
         'regionCode' => 'IT',
         'pageInfo' => 
        stdClass::__set_state(array(
           'totalResults' => 0,
           'resultsPerPage' => 5,
        )),
         'items' => 
        array (
        ),
      )),
       'arrayResponse' => 
      array (
        'kind' => 'youtube#searchListResponse',
        'etag' => '"XI7nbFXulYBIpL0ayR_gDh3eu1k/E4HxAVVo5-NQgTdQI4YY5CueOXk"',
        'regionCode' => 'IT',
        'pageInfo' => 
        array (
          'totalResults' => 0,
          'resultsPerPage' => 5,
        ),
        'items' => 
        array (
        ),
      ),
       'errorMessage' => NULL,
       'errorArray' => 
      array (
      ),
       'isLive' => NULL,
       'queryData' => 
      array (
        'part' => 'id,snippet',
        'channelId' => 'UCbYtiqpPtQjL3-U07v230Aw',
        'eventType' => 'live',
        'type' => 'video',
        'key' => 'AIzaSyARX0X78A8ws7TotoaNtIksMmK0qLqXpLA',
      ),
       'getAddress' => 'https://www.googleapis.com/youtube/v3/',
       'getQuery' => 'part=id%2Csnippet&channelId=UCbYtiqpPtQjL3-U07v230Aw&eventType=live&type=video&key=AIzaSyARX0X78A8ws7TotoaNtIksMmK0qLqXpLA',
       'queryString' => 'https://www.googleapis.com/youtube/v3/search?part=id%2Csnippet&channelId=UCbYtiqpPtQjL3-U07v230Aw&eventType=live&type=video&key=AIzaSyARX0X78A8ws7TotoaNtIksMmK0qLqXpLA',
       'part' => 'id,snippet',
       'eventType' => 'live',
       'type' => 'video',
       'subdomain' => 'www',
       'default_embed_width' => '560',
       'default_embed_height' => '315',
       'default_ratio' => 1.77777777777777767909128669998608529567718505859375,
       'embed_code' => NULL,
       'embed_autoplay' => 'true',
       'embed_width' => '720',
       'embed_height' => '480',
       'show_related' => 'false',
       'live_video_id' => NULL,
       'live_video_title' => NULL,
       'live_video_description' => NULL,
       'live_video_publishedAt' => NULL,
       'live_video_thumb_default' => NULL,
       'live_video_thumb_medium' => NULL,
       'live_video_thumb_high' => NULL,
       'resource_type' => 'live',
       'uploads_id' => NULL,
       'channel_title' => NULL,
       'completed_video_id' => '',
       'resource' => 'search',
    ))
     -->

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’ve added referrer and a new error arose when I click “check again”:

    WP YouTube Live error:

    Domain: usageLimits
    Reason: ipRefererBlocked
    Message: The request did not specify any referer. Please ensure that the client is sending referer or use the API Console to remove the referer restrictions.
    Extended help: https://console.developers.google.com/apis/credentials?project=492391758980

    Referrers are https://*.astelowfi.it/* and http://*.astelowfi.it/*

    Plugin Author macbookandrew

    (@macbookandrew)

    @kove,

    You should remove the referer restrictions, since the embedding is happening server-side instead of client-side.

    If I click the “all of our videos” link I am redirected to a blank youtube channel.

    To fix this, double-check your fallback message; it does not include your channel ID.

    I’m trying to live streaming in this page but I can’t.

    How long were you waiting between starting the livestream and checking the page? It can take a few minutes for caches to clear out and the livestream to start showing up.

    You should remove the referer restrictions, since the embedding is happening server-side instead of client-side.

    Done

    How long were you waiting between starting the livestream and checking the page? It can take a few minutes for caches to clear out and the livestream to start showing up.

    Several minutes

    Plugin Author macbookandrew

    (@macbookandrew)

    Are you streaming now?

    Note that streams have to be public, not unlisted or private.

    I’m streaming now.

    Note that streams have to be public, not unlisted or private.

    Ty, It was unlisted.

    Now it’s different but I still get an error:
    “watch this video on youtube. The reproduction on other websites has been limited by the author of the video”

    Plugin Author macbookandrew

    (@macbookandrew)

    >Navigate to the Settings Overview page for your YouTube content owner.

    when I click the links I’m redirected to a page that say I don’t have the authorization to see this page. The account is mine and only mine (wtf).

    Could you please tell me where exactly should I go?

    Wait, it seems crazy but I strongly suspect that in Italian the settings tab is totally missing.

    Plugin Author macbookandrew

    (@macbookandrew)

    Sorry, can’t help you much there…that’s all on Google/YouTube’s end.

    wait, do I need Adsense activated to enable the live video embedding?

    Plugin Author macbookandrew

    (@macbookandrew)

    Possibly…I haven’t kept up with YouTube’s requirements much lately.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘No live streaming’ is closed to new replies.