Support » Plugin: MC4WP: Mailchimp for WordPress » No lists were found in your MailChimp account.

  • Resolved Flea777

    (@flea777)


    I recently used the mailchimp service to send my first bulk email. Their automated system grabbed my email and mistakenly held it for a violation of their TOS. Once someone actually looked at the email, they apologized and freed it up. I then sent the emails.

    I don’t know if that has anything to do with anything, but funny how after that I noticed that the Mailchimp plugin was telling me there was not list in my account.

    It has my correct api key, I have reentered it just to make sure, it connects fine, but I can not select a list because it says there is not one in my account.

    Logging into their website, my list is indeed there.

    On their website under API calls in the last 24 hours it shows:
    2018-05-17 13:52:20 GMT nope 198.71.62.39 GET / php 0.024s mc4wp/4.2.1; WordPress/4.9.5; https://allans-stuff.com 3.0 n/a

    That time in GMT is about right for the last time I tried to get it to fetch a list.

    Help?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Lap

    (@lapzor)

    Hi,

    Let’s try and generate a new API key, fill the new key and then go to MailChimp for WP > Mailchimp and click the Renew MailChimp Lists button.

    Do you get any error when doing so, or do you see the lists appear?

    Hope that helps. If you have any questions, please let us know!

    Same thing with the new key. Interestingly enough, when I went to see if the new key connected correctly on the mailchimp.com website, I saw a bunch of errors from earlier….

    2018-05-17 16:37:20 GMT nope 198.71.62.39 PUT /lists/…/members/…/ php 0.074s mc4wp/4.2.1; WordPress/4.9.5; https://allans-stuff.com 3.0 Your merge fields were invalid.
    2018-05-17 16:37:20 GMT nope 198.71.62.39 GET /lists/…/members/…/ php 0.016s mc4wp/4.2.1; WordPress/4.9.5; https://allans-stuff.com 3.0 The requested resource could not be found.
    2018-05-17 16:37:05 GMT nope 198.71.62.39 PUT /lists/…/members/…/ php 0.105s mc4wp/4.2.1; WordPress/4.9.5; https://allans-stuff.com 3.0 Your merge fields were invalid.
    2018-05-17 16:37:04 GMT nope 198.71.62.39 GET /lists/…/members/…/ php 0.131s mc4wp/4.2.1; WordPress/4.9.5; https://allans-stuff.com 3.0 The requested resource could not be found.

    The new key though seems to connect OK:
    2018-05-17 20:24:31 GMT nope 198.71.62.39 GET / php 0.087s mc4wp/4.2.1; WordPress/4.9.5; https://allans-stuff.com 3.0 n/a

    But still have no lists.

    Also, don’t know if this matters but I just recently went to SSL (converted to https from http), installed a new cache plugin, and got a CDN.

    Plugin Contributor Lap

    (@lapzor)

    HTTPS/SSL should not influence this.

    I can imagine the CDN/Caching could affect things, if it’s caching the requests for the lists somehow and serving you the same old result, although that would be somewhat unusual.

    Is it possible to test with those turned off?

    This is the kind of stuff that makes me love vodka….. Everything just magically works this morning. No errors in the mailchimp.com api logs, the plugin shows my list, all is right with the world.

    Just to clarify, I did nothing after creating and installing that new key which didn’t work yesterday.

    Thanks for the assist.

    Plugin Contributor Harish Chouhan

    (@hchouhan)

    Hey @flea777,

    Thanks for the update and we are glad the issue is resolved. Like my colleague mentioned, this could be related to caching as it usually takes a while for it to be cleared automatically.

    Let us know if you run into any other issues.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘No lists were found in your MailChimp account.’ is closed to new replies.