Support » Plugin: Max Mega Menu » No links working except last menu item?

  • Resolved AFemaleProdigy

    (@afemaleprodigy)


    Hello. I am building my website and there seems to be a problem with mega menu. The primary navigation is to the right of the logo. “Website Services, Graphics, SEO, Email, Marketing”. When mega menu is enabled on that or any other menu, only the very last link in the menu is clickable. All other menu items do not respond to clicking. I have also enabled mega menu in the right sidebar menu (expand to view it). I get the same problem there. Which tells me it does not matter the location, nor which menu I use. The problem is there when mega menu is enabled. The problem goes away when it is disabled. I noticed the problem also goes away if I set the hover/click effects to “none”. This problem also happens on all pages of the website. I can see that the href links are there in the code, but something prevents them from working. I checked for overlapping objects that might block clicking, but cannot find any. I checked for z-index issues, but do not see any. And since this happens in different locations and each time it only applies to the last menu item, I do not believe it is a z-index issue. I also tried re-ordering the menu items to see if it was a certain menu item causing the problem. Result is always the same. Last menu item is clickable and no others. You can see the very top page menu does not have mega menu enabled and it works fine. I cannot find any settings that would cause this effect. I am at a loss here. Can someone please help? Thank you!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi AFemaleProdigy,

    I see the problem here also.

    If I disable JavaScript, the links work – so we know it is a JavaScriot issue rather than CSS.

    Please can you try removing this ‘mega-menu’ class from the <nav> element that wraps the menu?

    https://screencast.com/t/TzPM1PaJqxi

    It will be in your theme files somewhere, but I can’t tell you exactly where (all themes are different). If you struggle to find it, you could try searching all of your theme files for “main_mega_menu”.

    Regards,
    Tom

    Tom,

    Thank you so much! That worked perfectly. I removed that reference of mega-menu from both the primary menu and the right side menu.

    Have a great day!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘No links working except last menu item?’ is closed to new replies.