Support » Plugin: Link Library » "no links found to moderate"

  • Resolved alishayouch

    (@alishayouch)


    After being alerted by a numeric icon (and a user’s letting me know) that a user has submitted a link via the Link Library submission form, I am seeing a number “1” showing next to Moderate in the Link Library Menu, but when I click on the Moderate link and bring up that menu, there are no links shown for moderation, just the statements “no links found to moderate.” When I return to the Link Library Menu, the numeral “1” remains next to the word Moderate. After finding the same thing several times, I went into the Library Settings window, went down to the section titled “Link User Submission” and clicked on the “View List of Links Awaiting Moderation” hyperlink. When I clicked this, I was taken to my list of WordPress Links that were, in fact, awaiting approval, and the link that had been submitted was there. I tried submitting several test links myself, and I found the same thing repeated over and over again.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Bump. I am still having this problem. I am able to work around it manually, but I really would like to find links “to moderate” when I click on the notification that there have been new links submitted for my approval.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Hi Alisha,

    Sorry for the lack of response. Have been very busy recently and trying to catch up. I just tested the moderation link from the menu bar and it works correctly on my live site and my test site. I did find a problem with deleting unwanted links in the moderation screen for which I just posted an update.

    Please try upgrading and see if things are working better now. If not, I would probably need admin access on your site and database access to your mysql admin page to figure out what is happening on your install.

    Yannick

    Hi Yannick,

    Thanks so much for your reply. I have installed the most recent update, but unfortunately it did not have any impact on my issue. I will gladly give you admin access to the site and database access to our mysql admin page. Would you please email me privately at your earliest convenience so I can arrange for username/password for you?

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Sent you my e-mail.

    I have this problem too. I have last version of Link Library on WordPress 3.2.1 platform.

    I see that I have 1 link awaiting for moderation but if I clicked on the “View List of Links Awaiting Moderation” I found just “no links found to moderate.”

    I can approve links only by “unhide” them in standard screen of WordPress for edit links.

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Hi Alisha,

    The issue has been resolved. There was a problem with the code that was supposed to display the list of categories to submit the new links under. Since the list was not displayed, the new links submitted ended up with no category.

    You can now see on the site that the link category selection list is now being displayed.

    Ciprian, was the category selection list showing up in your link submission form before? Check to see if things work better with this new update.

    Yannick

    Yannick,

    Thank you SO much for working this through for me! It is working great, and I submitted several test links to ensure it was working correctly – it works perfectly. I figured out how to override the “show all” for the category dropdown list – you thought of everything!

    Thanks again!
    Alisha

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    Hi Alisha,

    Glad that this is working well for you and that you found the option to tailor the list of categories for the drop-down list.

    You can remove the admin account that you created for me.

    Hi again,

    The whole story was that:
    – first I try to add a link from frontend, without moderation and I saw that my link not appear to directory. I checked in backend and it was there – “unhide” them and I see on site.
    – I thought – “the link not appear because I didn’t set a category for them” – then I see that categories was set to show up but they don’t appear… testing various configurations let me see the problem with empty categories (was the moment when I write the other post)
    – because the links won’t appear from frontend, I think to let them “moderated”, so eventually subscribers will see that they links waiting for moderation and will be patients not worried because nothing happend. (Then I saw that moderations didn’t work neither and replied here)

    Now the problem is solved, links appear on site with or without moderation, and moderation link work perfect.

    Thank you kindly for your great work. In about a week I hope to finish romanian translation of Link Library for my site, if you need them I’ll be glad to contribute a little.

    Best Regards,
    Ciprian

    Plugin Author Yannick Lefebvre

    (@jackdewey)

    I would love to add a romanian translation to Link Library. That being said, the translation file is not fully up-to-date, so you will not be able to translate 100% of the strings. I will try to create an up-to-date version of the po file soon.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘"no links found to moderate"’ is closed to new replies.